Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

HTTP ERROR 500 beim speichern

Hallo,

wir bekommen seit einiger Zeit beim speichern von Firmen, Verkaufschancen, usw. einen HTTP ERROR 500. Wir arbeiten aktuell mit der Version V.9.8. Ein Update habe ich schon probiert, aber dort bekomme ich ein internat Server Error. Ich den log Dateien vom Hoster bekomme ich folgendes angezeigt. siehe unten.

Die Perfomance Tweaks habe ich schon probiert, leider ohne erfolg.
https://docs.suitecrm.com/developer/performance-tweaks/

In den Log Dateien suitecrm.log upgradeWizard.log konnte ich nicht außergewöhnliches finden. Es arbeiten auch nur maximal 2 Personen gleichzeitig.

Serverlogs nach dem Update:

14.01.2020 11:56:38 CRM.URL PHP Warning: Smarty error: Fehlendes Pflichtfeld:file in /mnt/web312/c2/10/5156410/htdocs/SuiteCRM-7.8.1/include/Smarty/Smarty.class.php on line 1094

14.01.2020 11:56:50 CRM.URL PHP Warning: array_map(): Expected parameter 2 to be an array, null given in /mnt/web312/c2/10/5156410/htdocs/SuiteCRM-7.8.1/include/SubPanel/SubPanelTiles.php on line 376

14.01.2020 11:57:32 CRM.URL FastCGI: “/home/strato/http/fastcgi/rid/64/10/5156410/htdocs/SuiteCRM-7.8.1/index.php” aborted: no response after 122 sec (idle timeout 120 sec)

Vorab vielen Dank! Ich hoffe mir kann jemand helfen.

Hi,
welche Version ist dem Einsatz? Und passt diese zur verwendeten Systemlandschaft (siehe compatibility matrix)?

Hey,

danke für den Tipp. Ich habe gesehen, das mein Provider nur noch PHP 7.2 und 7.3 anbietet. Laut den Voraussetzungen unterstützt die Version 7.9.x nur die Version bis 7.1. Meinst du, dass das der Fehler sein kann? Besteht die Möglichkeit manuell auf eine höhere Version 7.11.X zu updaten? Diese unterstützt ja die PHP ab 7.2

Danke!

Einige der Warnings könnte ich mir mit der php-Version erklären, aber ich bin mir nicht sicher ob das die Probleme behebt.

Notfalls könntest du ein Update auf z.B. localhost/ durchführen, da hast du mehr Kontrolle über php-Version und Co.

Hey,

ich habe es jetzt geschafft ein Backup der Datenbank zu ziehen und SuiteCRM per Xampp auf meinem PC installiert. Soweit funktioniert auch alles. Nun wollte ich ein Update auf die aktuelle Version durchführen und im Anschluss wieder auf unseren Webserver laden. Ich bekomme beim Aktualisierungsassistent folgende Fehlermeldung. Hast du noch eine Idee, an was das liegen könnte? Vielen Dank vorab!

Warning : include_once(C:\xampp\htdocs\CRM\modules\UpgradeWizard/…/…/include/Imap/ImapHandlerFactory.php): failed to open stream: No such file or directory in C:\xampp\htdocs\CRM\modules\UpgradeWizard\uw_utils.php on line 45

Warning : include_once(C:\xampp\htdocs\CRM\modules\UpgradeWizard/…/…/include/Imap/ImapHandlerFactory.php): failed to open stream: No such file or directory in C:\xampp\htdocs\CRM\modules\UpgradeWizard\uw_utils.php on line 45

Warning : include_once(): Failed opening ‘C:\xampp\htdocs\CRM\modules\UpgradeWizard/…/…/include/Imap/ImapHandlerFactory.php’ for inclusion (include_path=‘C:\xampp\htdocs\CRM;C:\xampp\htdocs\CRM\include\HTMLPurifier/standalone;C:\xampp\htdocs\CRM\include/…;C:\xampp\php\PEAR’) in C:\xampp\htdocs\CRM\modules\UpgradeWizard\uw_utils.php on line 45

Notice : Undefined index: LBL_CURRENT_PHP_VERSION in C:\xampp\htdocs\CRM\modules\UpgradeWizard\uw_utils.php on line 1126

Fatal error : Class ‘ImapHandlerFactory’ not found in C:\xampp\htdocs\CRM\modules\UpgradeWizard\uw_utils.php on line 1171

liegt es vielleicht an den Ordner und Datei Rechten ? Damit hatten wir zum Start auch Probleme.

Unter xampp/Windows eher selten, da kenne ich die Problematik eher aus dem IIS-Kontext.
Hast du versucht die Klasse mal per require_once aufzulösen? Die Warnings/notices sind relativ normal, nur der fatal error macht mich stutzig.

Danke für eure Antworten. An den Berechtigungen kann es meiner Meinung nach nicht liegen. Diese habe ich gesetzt. Ich habe es jetzt bei einem anderen online Hoster aufgesetzt . Da funktioniert alles ohne Probleme. (Hoffe ich :smiley: ) Obwohl es die gleiche Installation und die gleiche Datenbank ist.