htaccess error -> "Options not allowed here"


If you are getting a “Server 500” error and your log files say “…htaccess: Options not allowed here…” it is because the code in ./install/install_utils.php uses an older syntax which cannot be mixed with the newer syntax, so if the server config files are using the new syntax, you will get this message. The quick solution is to comment or delete the line in .htaccess that says “Options +FollowSymLinks”.

I don’t think there is a way for PHP to find out Apache settings unless something like mod_info is installed.

1 Like

I had the same problem. Here is how to solve this.

To get rid of this entry in the .htaccess you have to make following changes in the code (Version 7.8.3):

In the “install/install_utils.php” on following lines:
957 - Options +FollowSymLinks
957 + #Options +FollowSymLinks
958 RewriteEngine On

and if you upgrade in “modules/Administration/UpgradeAccess.php” on following lines
63 - Options +FollowSymLinks
63 + #Options +FollowSymLinks
64 RewriteEngine On

This solved my problem. Hope this hels someone with the 500 Error at installation.
And I hope that we don’t run into problems with that comment :unsure:

Have a nice day