How to solve labels "undefined" without SSH access

Hello everyone!
I have a problem mentioned many times in this forum but none of the solutions works for me - I don’t have SSH access in my cPanel nor terminal window (command line) tool to perform needed commands.
I can only change permissions via File Manager in cPanel.

So far I have noticed “undefined” labels in Quotes > Line items.

I’m using SuiteCRM in subdomain and .htaccess file has RewriteBase set to: RewriteBase /

I did entire installation process without any warnings or errors. Other important details (the ones I can think of right now…):

  • SuiteCRM version 7.9.9.
  • PHP version 7.0

Exactly what files and folders should I change permissions for?
What kind of permissions to associate with those files/folders?
Do I need to alter .htaccess file?
Do I need to perform some kind of repair task in Admin module after each action on server or can I do only one after I’m done with changes of server?
What repair tool should I use?

So many questions, I know… So I thank you for looking into this topic and I appreciate any kind of help!
Thank you in advance and best regards,

Hi, let me try answering some of those questions…

  • not having SSH access is a real nuisance for a SuiteCRM system. It’s not a small app, and it’s not a simple app. It requires some administration work and SSH is very useful for that. Consider moving to a better hosting.

  • if you didn’t change .htaccess, and your hosting didn’t change it (because SuiteCRM installer creates one), you shouldn’t have to worry about it.

  • you can do a Quick Repair and Rebuild only once at the end of everything

  • the desired ownerships and permissions can perhaps be attempted from CPanel, in some File Manager, or via FTP.

  • the recommended permissions are those set by these commands:

    sudo chown -R www-data:www-data .
    sudo chmod -R 755 .
    sudo chmod -R 775 cache custom modules themes data upload config_override.php

Those are recursive commands so they apply to every file and directory below the mentioned names. If you can’t find a way to do it all automatically, it’s practically impossible to do it one by one.

  • finally, I wouldn’t immediately assume you have permissions problems. If you had them, you would likely see “undefineds” in several places in the app, not just in one. If it is only in that particular screen, it might be a bug,m or a different problem, or a language pack problem, etc.

If you go into Admin / Upgrade Wizard, and run just the first step of the wizard, it will do a permissions check for you. It is not conclusive, but it might give you some clues.

Hello pgr!
Last thing first: I did run Upgrade Wizard and System check came back with this:

[quote]File Permissions: All Files Writable
Database Privileges: All Privileges Available
Detected Settings: All System Settings Requirements Satisfied[/quote]
I assume nothing’s wrong about permissions then…

Next, I do have SSH access pane in cPanel but there’s nothing in it but

I guess I need some Terminal pane or Command line to execute those commands (which I don’t have in my cPanel) you have provided and right now I’m also writing to hosting support to solve this.

“Undefined” labels are not restricted only to Line items in Quotes, this issue appears in various situations but in Quotes and Invoices it’s most annoying. In attachment you can see how awkward it looks while one is editing a quote and labels are undefined but exported PDF has correct labels.

I haven’t change the default language, and maybe it wasn’t the best idea to install the system on a shared hosting server but it seemed logical because I’m trying to set up the system for my friend’s firm and I should be able to react - at least in the first couple of months - if they got stuck up or something goes wrong.

However, this was only a test installation so we could see the features of the system in environment predicted to be used in. It’s still in testing phase and we have enough time to deal with this issues before the real installation takes place. So far, I’m very pleased with robustness and possibilities of this CRM and I would definitely recommend its use even if some minor issues won’t be fixed during the test phase.

I’ll get back after I find out what can be done on hosting side. For, now, thank you very much for clarifying this for me, I’m only an user, PHP and SSH are really not my thing so it’s a struggle for me but that’s the way it should be I guess. :slight_smile:

Best regards,

As I said, the upgrade wizard check is not conclusive, it’s a partial check only. Actually - it’s not conclusive when it’s positive, it IS conclusive when it’s negative. :slight_smile:

There are many shared hostings that offer you SSH access, it’s a matter of selecting the right company and the right plan. If there is no way to set ownership and permissions yourself, you can ask your hosting to do it for you.

Short and sweet.

Any PHP App that requires you to play with SSH just to fix up “Labels” is not something we’d use.

I been devving for years. And never had this issue on anything else - from Drupal, Joomla, Wordpress, Magento, my own apps, tonnes of apps. Never seen a support forum tell their users that getting “UNDEFINED” everywhere was just their fault for not being able to utilise SSH.

The whole app is buggy, UX is shocking.

We’re out. Will be uninstalling this afternoon. I am gutted as I really thought we had found something we could offer our SME clients to get into.

Real shame.

SuiteCRM is an application that writes itself. Not all applications are.

If it writes itself, changing configuration files (for labels, fields, layouts, etc), it needs to write changes to disk. It is immensely configurable.

If it needs to write changes to disk, it can’t work in an environment where these changes are not allowed by the OS (and its sysadmin). It cannot work miracles around your OS’s security.

You don’t need to have SSH access, you can give permissions in many ways: your hosting can do it for you, you can use a file manager, hire a consultant with all the money you saved by using a free app, etc. But really, you might be “devving for years”, but your complaints in this regard are simply and truly unfair.

It’s also not that different from other apps you mention, you were just lucky, as these hundreds of thousands of search results attest:

I can install a SuiteCRM server in 10 minutes, including download times, and get it up and running flawlessly. Don’t blame SuiteCRM for the hurdles your Hosting adds.

My hosting company answered with with resolute “No!” on my question if I can get SSH access on my subdomain. “For security reasons”, they said… Same host (I maintain and design many websites hosted at very same hosting company) used to allow shell access via cPanel until a few months ago. Now I have to find the way to make permissions work the way I need them to via FTP or File Manager.

I’ll deal with “undefined” labels and permissions later. I’m still exploring SuiteCRM and learning its environment and workflow. I want to be sure it’s the right choice for my friend. At this moment, I’m very satisfied with what I have seen and learned so far - it’s a quite robust and flexible app with many things to configure to meet one’s needs.

Yes, some things are a bit confusing in the beginning, some things seem not to work (uploaded product image not showing) but those things are not that much frustrating as it may seem and certainly they don’t affect the global functionality of the app itself.
Also, it’s not some kind of plug-and-play solution, this app needs more involvement and work to polish its environment so the user could be able to use app’s full potential. Which is huge, imo.

I’ll be back to this topic when I’m done or stuck with permissions and “undefined” labels, with my experience elaborated or with more questions.
Until then,thank you for help and tips!
Best regards,

I would never, ever, use a hosting that didn’t give me SSH access. Yes, that requires them to make the SSH shell very protected and limited, but there are ways to achieve that, and many hostings do.

SuiteCRM does not claim to work on every hosting out there. If you choose a hosting that limits your ability to configure necessary requirements, you’re bound to get into trouble.

On the other hand, I would say literally thousands of hostings will be good enough to run SuiteCRM. There are plenty of choices.

1 Like

To solve your problem (only on Linux) you can try my script:

Normally it works fine.


Usually, I would advice my friend to make the same decision, to choose a hosting with appropriate configuration for SuiteCRM. Unfortunately, he has long term contract paid up front and it lasts for next three years. So I must find a workaround. :slight_smile:



It worked like a charm! One run only, even without Repair and Rebuild! Great script and really a time-saver solution!
Thank you amariussi so much!

I would recommend this solution whenever I see the same problem posted on this forum.
Best regards and have a nice day!

I am glad it worked!

In addition to running manually the script I have also created a custom SuitecRM scheduler that runs it every 15 minutes.

Not a great solution but effective.

If you read @Pgr’s blog there is a more “professional” approach to the issue but I believe that yo may not have sufficient access to your server to implement it. I any case, when you have time give it a read and possibly a try.


HUmm, Yes, I tried running this “chperms” PHP, and ran back and forth three times, then Quick Repair and Rebuild, and cleared the browser cache … Rebuild .htaccess File … there is no change. “undefined” till right here LINE ITEMS and arround STUDIO too… i tried more and more (firefox, Chrome, IE)

*php7.0 / Suitecrm 7.10 / Linux shared hosting / Apache server

How can i fix ???

[quote=“hoasenvang7799” post=62829]

100% this issue come form .htaccess - why ? Try uploading a white htaccess file, it will run immediately, or you can add the # sign to the two lines on the same way.

RewriteRule ^cache/jsLanguage/(…_…).js$ index.php?entryPoint=jslang&module=app_strings&lang=$1 [L,QSA]

RewriteRule ^cache/jsLanguage/(\w*)/(…_…).js$ index.php?entryPoint=jslang&module=$1&lang=$2 [L,QSA]

*This way to leave “undefined” text !

@hoasenvang7799 there were several fixes recently to the .htaccess handling. Are you on 7.10.0? If so, please try the latest 7.10.2

Hello @pgr i’m really update to 7.10.2 all “undefined” had gone but “There is no image show on Product add new” had come - now the time to find out this issue

Thanks for your script amariussi - I was about to give up on SuiteCRM but your script fixed all the undefined errors immediately

Is this applicable to version 8.1.2, with PHP version 7.4.30?

I am hosted at, I have the same undefined in a lot of fields.

All versions of SuiteCRM need read access to all directories, and write access to some directories, as indicated in the installation instructions.

SuiteCRM 8 has additional requirements (a crucial htaccess redirect).

Yup, all folders and files 755. Unfortunately, I’m having undefined issues. What are other htaccess requirements? Mine only shows

RewriteEngine on
RewriteCond %{HTTP_HOST} ^$ [NC,OR]
RewriteCond %{HTTP_HOST} ^$
RewriteCond %{REQUEST_URI} !/suitecrm/public/
RewriteRule (.*) /suitecrm/public/$1 [L]