How to add users with username and password?

Hello everyone!
I’m new to SuiteCRM (version 7.9.9) and I have a problem with Users which I can’t resolve by reading Users Guide nor Community Support Forum…
I simply can’t find the way to add not even one extra user (after adding the initial one - me) who would be able to log-in on it’s own - no Password Tab in User Preferences! And that’s not the only thing that’s missing: no Admin section, no Themes Tab, no General Setting (or similar section) to change Email preferences, etc…
Maybe it takes a little more time for me to get used to UI but for now I feel like I’m moving in circle and just can’t find the way out.
I would really appreciate any help on this issue!
Thank you in advance and best regards,

There are two settings in password management.

  1. Auto generated. In which case you will not see the password in the users profile. It sends the new user a link and auto generates a password.
  2. If you set it to passwords, you can manually enter a password and send it to them. Then you will see the password tab in the user.

Not sure it that’s your issue or not, but try that if you haven’t already.

Thank you for your answer pstevens but I can’t set passwords either way because the system does not offer that option. Or I can’t find it?
Where can I look for password setup?
And, btw, my first created user was immediately granted with option of manual password. Others didn’t and since there is no mail settings tab, I can’t check if the mail is working or not.

Admin… Password Managment… then right at the top, uncheck “enable system generated passwords”

That should allow you to see the password tab in the user profile.

If not, you’ve got a problem.

I find 90% of problems are fixed by 2 things:

1)Do a quick repair and rebuild in the “repair” menu
2) with Putty re-do all your file permissions with CHOWN command

If none of that fixes your issue you try to test and see if it works on the Demo installation on the SuiteCRM website.

If you get the issue on the demo install, you should open a bug on GitHub.


Thank you!
I’m not at my computer right now but I’ll check it out and get back here with the results.
Best regards!

It sounds like you’re logged in as a non-admin user…

You can compare what you see with these two online demos.

Regular user demo:

Admin user demo:

Also, don’t confuse Employees module with Users module. To be honest, they are a bit confusing, since names you create in one will show in the other. But if people should have a log in, they need to be Users.

1 Like

This solved my problem I think! Now my extra user have Password Tab in User profile and I was able to log-in under his name.
Then I was also able to change personal settings right after the login window (User Wizard).

About that, a little note to developers or writers of User’s Guide:

User’s Guide explains this step but… It seems the very first log-in to the system is, by default, an admin log-in and in such case there is no User Wizard at all. It is a bit misleading for newcomers like me. I thought something went wrong with the installation and did it all over again, or maybe this step was removed in the latest version or… whatever. This could be explained a bit better in User’s Guide.

Anyway, thank you for helping me to solve this issue and have a nice day!