Home page dashlet url not getting current link SuiteCRM 8

i am trying to run a file from current location in home page dashboard web dashlet ,
but dashlet showing “Incorrect website location is specified”.
i tried EntryPoint also but same result

but previous version crm not make this issue .
does somebody know how to achieve this

1 Like

I’m having the same issue with an entry point. I’ll update if any solution. In your case, try https://

1 Like

I am having the same or a very similar issue. SuiteCRM 8 on hosted platform.

On our test platform, I registered an entry point and dropped the code file into the custom directory in order to produce some Google charts as web dashlets. On the test system, which is local, I did this and it worked perfectly and we can produce really good charts and incorporate them into the main dashboard for sales forecasting and the like.

After extensive testing, I moved the entry point code onto the hosted production platform and ran a rebuild to register it. This worked fine.

I then loaded the first chart code into the custom directory and tested it in the Chrome browser using the URL
This also worked fine and displayed the chart as per the code and as per the test system.

I then went into SuiteCRM on the hosted platform and via the ‘Add Dashlet’ function, added a web dashlet with the URL address, being identical to the one I had just run and which worked fine. However, this generates the ‘Incorrect website location is specified’ message on the dashboard.

I have tried just using http but no joy and have played around with various combinations but cannot get this to resolve even though it works fine from the same google chrome browser I am using as just the URL.

Any help gratefully received as this is driving us crazy.

There was a security patch that prevents iframe links from the hosted application. I think it was some measure to prevent SQL injection. Anyway, I came up with a method to bypass this and to specifically allow entry points registered in SuiteCRM. You can find my code here. It should solve your problem.

Excellent. Thanks @pstevens . I will try this tomorrow before everyone gets onto the system and see if it does the trick.

I’ll let you know either way.

Thanks again.

Thank you indeed.

I did the initial change - blanking out the 3 lines in the iFrameDashlet.php to check that this would fix the problem. Which it did and the dashlet displayed fine once I had entered the URL into the address box on the dashlet Web setup page. I asked a few users to do the same thing and all worked fine.

I understand that this is not the full fix and leaves a security vulnerability, which your full fix addresses.

The only issue I have is that I understand adding the function into utils.php but then the second element of the change talks about modifying the getCustomEntryPoints() function.

Where I was slightly confused is where this code goes - is it in the utils.php after the previous function definition (which is what I am assuming) or is there something I am not seeing.

It also refers to localhost and HTTP_HOST in the second function code. As we are on a hosted platform will this work. Something I have never tried.

I want to implement the correct fix but if I could just check the above with you, this will save time as I am not an out and out coder, as you can tell, and keen not to mess up our test or production platform.

Hey @ggraynoth, you need to add the new function to utils.php and then modify the existing second function in utils.php listed in the bug report I posted.

You do not need to make any modifications to the code I posted, it will work on your hosted environment.

Thanks thats great. Just done and works fine.

Many thanks for your help. Much appreciated.

What about a github PR @pstevens ? Registered entryPoint should be OK in dashlets.