Help text not working

I’m trying to add help text to my “CUIT” field, which belongs to the Leads module (inside the “create lead” menu), so that users know the format of the value to enter. My intention is to have a placeholder in this field that says “xx-xxxxxxxx-x,” providing useful information to the user.
The “CUIT” field is created from Studio, and I noticed that it has the option for “Help Text” when editing that field, but it’s not working because it doesn’t provide any information, and I would like it to be visible or add a placeholder.

Does anyone know why it’s not working? Or how can I make a placeholder appear?


I want a label/placeholder to appear as in the case of this field:

Help Text: Optional explanatory text to display temporarily when the user hovers over the field.

Maybe logic hook will work:

Is there logic hook for DetailsView?

Just in case you don’t know help text doesn’t work for admin, it works for everyone else. Check as a user.

Sounds like a bug. Is there any good reason for the help text to not work for admin?

I have verified using a non-administrator user, and the help text is still not visible… I agree with chris001 that it’s a bug. Moreover, I’m also unable to find a way to add it to the field as a placeholder. I’m still searching for a solution to this issue… :sweat:

Hey @Tatiana I just tested it out and it works see below: (OH and it does work for Admin as well, must have been fixed, last time I had an issue with it the issue was it worked just not for admin, but that looks like it’s no longer an issue).

Might be a browser issue. What browser are you using?

I’m surprised, it doesn’t work for me either, even when using a non-administrator user. I’m using the Google Chrome web browser. Look, neither hovering over the CUIT field nor clicking on it shows the help text. I’ll also show you the help text field from the studio so you can see it’s modified, but nothing appears for me

Hey @Tatiana I can confirm. It does not work in SuiteCRM 8. This is a bug.

How can this error be reported in SuiteCRM 8? … Sorry to ask, I’m new to SuiteCRM and there are still things I’m learning.

one more thing, you can see that ‘help text’ when you’re in edit view of the module.

You just need to hover over it.

It is working in v7.x. Maybe it is just bug with v8.x versions.

Exactly, it’s very likely to be a problem with version 8.

@Tatiana there is a fix proposed, you can try applying it and see if it works for you.

This is the fix proposed, it’s just 2 changed <a> links, and 1 added <span>:

@Tatiana, Please make these code changes and let us know

I’m testing the change, I’ll let you know/confirm if it worked in a moment.

I applied the changes in the file as indicated by the Fix, exactly as stated. Then, I accessed the Admin/Repair section and initiated the ‘Quick Repair and Rebuild’ to apply the change from the file. I logged out as the administrator user, and logged in with a non-administrator user, but I don’t see any change. The issue was not resolved.

In the Admin/Studio section, the Help Text field is set to the value as seen in the image, but from the file ‘_override_sugarfield_cuit_c.php’ in the path ‘/public/legacy/custom/Extension/modules/Leads/Ext/Vardefs’, where that field should be reflected, it’s not there.


Sorry, perhaps you can help us with this issue? @pgr

You should run the command to clear the Symfony cache:
./bin/console cache:clear
then try it again.