Gsuite Outbound Issue

I have installed the Version 7.10.5
Sugar Version 6.5.25 (Build 344)
But my outgoing email of Gmail is not working.
It is giving me the error:
SugarPHPMailer encountered an error: SMTP Error: Could not connect to SMTP host.

but my imap is working fine.
Can anyone help please.

Please start by upgrading to 7.10.6 which just came out and fixes some SMTP bugs.

Then, is that error showing in the configuration screens (which ones?), when you click “Send test email”? If so, it should show you a button saying “STMP full log”, what does that give you?

Dear Admin, I have updated the version as mentioned and I still get following error:

If i user SSL, 465 then I get this error

3: Connection: opening to ssl://, timeout=300, options=array (
3: Connection failed. Error #2: stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages:
error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed [C:\HostingSpaces\admin\\wwwroot\include\phpmailer\class.smtp.php line 299]
3: Connection failed. Error #2: stream_socket_client(): Failed to enable crypto [C:\HostingSpaces\admin\\wwwroot\include\phpmailer\class.smtp.php line 299]
3: Connection failed. Error #2: stream_socket_client(): unable to connect to ssl:// (Unknown error) [C:\HostingSpaces\admin\\wwwroot\include\phpmailer\class.smtp.php line 299]
1: SMTP ERROR: Failed to connect to server: (0)
3: SMTP connect() failed.

BUT if I use TSL , 587 , then it is not showing any error but test email is not going as well.
I have installed it on IIS

I think to use SSL you need to install a certificate on your server. You can buy one, or get a free one from Let’s Encrypt.

Other than that, you need to debug this as a networking/SMTP issue. Check network connectivity, ports and firewalls, certificates and DNS resolution.

But I have paid email account from google.
Can I not just enter the google email and run it?

If you want to use a security scheme that uses certificates, you need certificates. If you use a different security, then you might me able to skip certificate configuration.

Gmail has it’s own peculiarities with security. Try searching for an option called “allow less secure apps”.

Hello Karma,
Yes I have Done that setting.
As I can access my gmail from the outlook as well. So my settings are fine.
Just it is not working on the CRM to send emails.
it is important for me to send emails from CRM to test Marketing section.

With TLS setting, try uncommenting this line here

And check that your values are ok at the moment when they go out to the server. Especially “From” and “From name” as there are still bugs breaking that in some places.

You can also use the lines above as a temporary workaround, to hard-code the values, until any bugs get fixed.