Googly Sync - CRON


After I did the last step in Google Sync → Google API Token:

Current API Token is: [color=#008800]CONFIGURED [/color]
Enable Calendar Sync: X

The CRON Error showed up

Please help

Why do you call that a “Cron” error? What does this have to do with cron?

That error seems to be coming from Google, did you do this configuration correctly?

I’ve followed every step of the documentation. (tried few times)

In SuiteCRM I was able to log in with my Google Account so the Status changed to green CONFIGURED.
And this Error showed up in Cron on server.

Sync with Google is still not working.

After I did the whole process once again the /cron.php showed this.

Could it be problem on our server´s side?

Hold on a second… I’ll take a look at this shortly.
Also note that there is a PR pending that cleans up the Google Sync code quite a bit, and fixes some bugs:


Please post the contents of your client.json file you downloaded from google. You can obfuscate the ‘client_secret’ tag.

Also, to debug, go to and revoke the permissions for SuiteCRM. Then reauthorize.


Hello Benjamin,

I tried to debug and reathorize, but with the same result.

Here is the content of JSON → {“web”:{“client_id”:“”,“project_id”:“suitecrm-sync-225113”,“auth_uri”:“",“token_uri”:“”,“auth_provider_x509_cert_url”:“”,“client_secret”:“xxx”,“redirect_uris”:["”]}}

Now I am trying to clean up the sync.

Thanks for helping me

Cleaning didn´t help :frowning:

This is strange. It seems that it’s getting a 404 error when trying to connect to the Google Api servers.
That shouldn’t happen :stuck_out_tongue:

Is the CRM server behind any kind of firewall that would prevent it from making an outgoing connection?

For more debugging info, you can add the line:
just above the cron.php cron job. That will output full debug logging just for the sync process to suitecrm.log.

I would like to try, but I ´ve lost the 7.11 version and there is just 7.11 - RC now without this Google sync :confused:

I don’t understand… 7.11-RC has GoogleSync. I’m working on it now. :\

Thank you Benjamin, wish I could help you somehow.
2 times reinstalled. Still I can´t see the Google Authentication subpanel in System Settings from previous beta version. So I can´t even put in JSON file.

AH! It’s been moved! Someone else is working on that part I guess. I just noticed lol. The Docs will need to be updated when their done.

Here’s what it looks like on mine. It’s been moved to a ‘GOOGLE’ section on the admin page. It’s the last item.

Ohh, nice catch, got it :slight_smile:

I ll try it and see if it works :slight_smile:

So I tried it again:

  • JSON file is: [color=#004400]CONFIGURED[/color]

  • Google Account Synchronization
    Current API Token is: [color=#004400]CONFIGURED [/color] (When I was authorizing my Google account from CRM, I did’nt have to confirm the Calendar approval like before)

-[color=#008888] No more Cron error ![/color]

But the Calendars are still not yet synchronized :confused:

Is it moved again? I am unable to find it anywhere on my systems page

Its been moved to the Admin Panel. See attachment. :slight_smile:

I do not have the same admin panel as you.

My admin panel says Google Maps not Google Suite and does not include the Google Calendar setting

What version are you currently on? This was moved to this new position since 7.11-RC2 and is in 7.11.0