Google Maps Scheduler refuses to run

Hey guys,

I have a cron setup hourly with the following URL:


It runs, and each task shows “complete”, but no updates are made to maps. I have to manually “geocode addresses” to get my maps to update.

Any idea what the problem might be? I’ve also tried the full URL, but that doesn’t work either.

I’m running on IIS 7.5 and MySQL (whatever the latest version is.) Thanks in advance for any advice.

Hi there,

This bug was highlighted previously. You actually need to specify the full URL i.e. yourcrmurl/index.php?module=jjwg_Maps&entryPoint=jjwg_Maps&cron=1



Hey Will,

Thanks for the suggestion. Unfortunately, this doesn’t work for me either. Would it have anything to do with the fact that my site is running SSL exclusively? I do not seem to recall having this problem before making that particular change.

I’m fairly certain that I haven’t done anything wrong. The site URL is properly specified in the Sugar config file, Windows/IIS has all of the proper rewrite rules, and nothing else seems to give me an issue. All my other scheduled tasks seem to run just fine.

I might add that I’ve tried the following variants of my URL:


Only the first one will reach the “Done” status after queuing up. The rest of them will sit in the queued status for a while, then fail - and will never run again after that.

Any other advice?

Hi Roquefort

You can’t call a URL from Cron in this way. Cron can only execute inbuilt system commands or shell scripts. So to do what you are looking for your would need a script.

Google cURL, and Bash for help on doing this.

Hope this is useful

Thanks guys. Turns out that this was related to my Workflows problem here:

Maps seem to be working now!