Google Calendar Sync

I’m following the tutorial on how to enable Google Calendar sync but it’s not working out.
Just upgraded to 7.11

Created new credentials in google API

But i don’t understand this section:

For Section 2, give it a descriptive name. Leave ‘JavaScript origins’ blank.
Under ‘Authorized redirect URIs’, you need to fill in the full URI to the ‘saveGoogleApiKey’ Entry
Point. Note that this does not need to be a public URL. It only needs to be accessible to the user who is
enabling the calendar sync. I’d absolutely recommend having an https enabled site for production on a
publicly accessible site.

What url am I supposed to paste?
I tried pasting this -

But it doesn’t work.

The tutorial doesn’t say a single thing on where to get this url.

Please help.

I´m having similar issues:

  1. The reference page in does not reflect what Google Console shows on screen, but I managed to enable GCalendar API and create a new credential for this anyway.

  2. After I click “Allow” (access to my GCalendar, in the Google account selection page), instead of “returning to SuiteCRM”, I get a blank page.

The problem seems to be the callback URL generated by SuiteCRM, which does NOT include the (web) folder in my server where my SuiteCRM instance is installed.


I think if you don´t have your SuiteCRM installed in the webroot folder, it won´t work !

I have the same problem. Is there a guide for setting up the Gsuite calendar synchronization with Crmsuite 7.11.0?
Thank you

I was able to get it working, did you try including the sub-folder in the callback URL?

Now I just need to figure out how to have it sync with my actual calendar instead of creating a new calendar called “SuiteCRM” :frowning:

How did you managed to get it work?
I click on authorize and I always get a blank screen.

URL should be “authorized” from google? Do I need extra credentials?


I managed to get until I click “authorize” from google.

After that, I return to a url:

and I get a Gateway Time-out :frowning: [cry]

of course i changed mydomain and long_code_here to make it readable.

Any suggestion?

I tried to tamper with the generated URL in order to include the missing web folder my SuiteCRM is installed in. But Chrome seems to get stucked in a “form submission” loop and doesn’t get back to the Administrators page

Now I’m trying moving the installation one folder up, to the web root to see if this will finally solve this.
.anyways: is there a place where I should configure the callback URL? Is it just there in the Calendar settings under /profile ?..


My instal is in a sub folder and I dont get this error at all.

In fact everything worked great, no error, I got everything like in the doc (

But now that everything is correctly setup, nothing happen in my calendar, he’s still empty ahah

Will follow this topic to see if someone got the same error.


In fact I’ve got a 301 error on the

“GET /index.php?entryPoint=saveGoogleApiKey HTTP/1.1” 301 - "

When I go myself to this URL it re direct me to /index.php?module=Users&action=EditView&record=1

So I think that the problem !

Note that 7.11.1 is out, it includes some bug fixes that might be relevant to these issues.

Yup, im already in 7.11.1 ! It not fix this issue

Could you correct the error? I have the same problem.

Hey folks! Any updates on this issue with latest version (7.11.3 as of today) ?

Would be nice to finally have Google Calendar as the main calendar for SuiteCRM !

update to version 7.11.3 and the problem persists :unsure:

1 Like

I have the same problem: I click on authorize and I always get a blank screen.
Version: 7.11.3

Does someone have a solution for this?

I got it to work. The file “cacert.pem” was missing. I download it from I put the file in php directory. I modified the php.ini to add (or uncomment) these 2 lines:

curl.cainfo=“C:\Program Files\PHP\v7.2\cacert.pem”
openssl.cafile=“C:\Program Files\PHP\v7.2\cacert.pem”

After this, I was able to authorize my user in SuiteCRM.


Is there any update here? It looks like everything is fine, but there is no sync.
user request access to google, all is good, but nothing happens in the actual map.
did someone get this working?
Thanks for any feedback!

It worked for me! Thanks. :facepunch:

1 Like

How is everyone liking the google calendar in the CRM? Working well? IM also considering a addon that does this , email and more