Google Calendar OAuth on v8.1.2

Can someone please confirm whether the Google Calendar Syncing actually works in SuiteCRM8.1.2, and if it does, can someone please help me out here.

I have followed various posts on setting up the OAuth json file etc, uploaded the json file to SuiteCRM, which says it’s configured. However when I try to authorise the API Token in the profile settings → GOOGLE ACCOUNT SYNCHRONIZATION. I simply get a blank screen and nothing happens. Nothing is authorised when I go back to the settings.

I have tried various changes to the ‘Authorised Redirect URI’ without success. Currently it is;

https://www.mysite.com/crm/index.php?entryPoint=saveGoogleApiKey

As a side note, I have successfully got maps to work with API key etc, so I know that internet connectivity from my host is not the issue.

Thanks in advance.
Terry

Is anyone able to confirm and/or help please? Would love to get this working.
Thanks

I don’t know about the specifics of what you’re asking, but you might be able to make some progress if you hunt for relevant errors in both your logs, at the time when that blank screen appears. Then you can Google for those.

Hi @TerryL
I understand your query.
Please check whether your google calendar setting is enabled or not
properly.
Please follow this step Google Calendar API: How to find API Key for Google calendar?
Or watch this video: How to Create and Download a JSON file from Google Developer Console - YouTube

I still cannot get the OAuth consent screen to appear after clicking ‘Authorize’ in the Google Account Sync section of Profile settings.

I have noticed that each time I choose the JSON file (downloaded from google) and save in the Admin → ‘Google Sync Settings’ the following error appears in SuiteCRM.log

Thu Sep 22 04:25:36 2022 [2344628][1][SECURITY] Invalid ext logger_file_ext : ‘’.
Thu Sep 22 04:25:36 2022 [2344628][1][SECURITY] Setting logger_file_ext to ‘.log’.
Thu Sep 22 04:25:36 2022 [2344628][1][SECURITY] Setting logger_file_name to ‘’.
Thu Sep 22 04:25:36 2022 [2344628][1][SECURITY] Log file extension can’t be blank.

Can anyone make sense of this for me please? I have spent days on this and getting nowhere.

Thanks
Terry

I’m seeing those same messages in SuiteCRM 7.12.x.

I don’t think they’re your real cause of concern - I did a little debugging and they don’t seem to be blocking anything, they’re false positives.

I am not 100% sure of this, though, it was just a quick look.

If you find your JSON (encoded) inside config_override.php, element $sugar_config['google_auth_json'] , then you know it saved successfully.

… though that leaves the question of why it doesn’t work then…

Hey
In Old 7.x version it worked by opening the Google Auth screen in the same page But in 8.x version this does not work
Please modify the file public/legacy/modules/Users/tpls/EditViewFooter.tpl line number 482
From

<slot>Current API Token is: <span style="color:{$GOOGLE_API_TOKEN_COLOR}">{$GOOGLE_API_TOKEN}</span> &nbsp;&nbsp;<input style="display:{$GOOGLE_API_TOKEN_ENABLE_NEW}" class="btn btn-primary btn-sm" id="google_gettoken" type="button" value="{$GOOGLE_API_TOKEN_BTN}" onclick="window.open('{$GOOGLE_API_TOKEN_NEW_URL}', '_self')" /></slot>

To

 <slot>Current API Token is: <span style="color:{$GOOGLE_API_TOKEN_COLOR}">{$GOOGLE_API_TOKEN}</span> &nbsp;&nbsp;<input style="display:{$GOOGLE_API_TOKEN_ENABLE_NEW}" class="btn btn-primary btn-sm" id="google_gettoken" type="button" value="{$GOOGLE_API_TOKEN_BTN}" onclick="window.open('{$GOOGLE_API_TOKEN_NEW_URL}')" /></slot>

Basically opening the Google Auth screen in a new window
When Auth is complete close this new window and refresh the profile page

This should get you going till there is a better solution

1 Like

Thank you, Thank You, Thank You! I have been going around in circles for days, trying to work out what was going on here. I had it working on SCRM7.12.7 on my localhost but with all the same procedures, SCRM8 refused to play ball.

Anyway, this will allow me to move on. Thanks again.