📣 We're Hiring!

Google Calendar integration - API token will not authorize

I have installed SuiteCRM to a local server (running at localhost) and all is working fine. I have been able to integrate email and other features, however I am struggling to get Google Calender integration to work.
I have followed the installation guide without error, generating the API Key, JSON script etc. However, after I step through the token validation process I still get the message: Current API Token is: UNCONFIGURED

I have searched this forum and tried various “tricks” that others have suggested. I have even gone through the process of setting up my local server with an SSL - but I still can’t get the API Token to CONFIGURE.

Any help greatly appreciated.

For Google Calendar Integration, Needs to Create Project on Google Developer Console

Click on Link for open Google Developer Console : Google Developer Console

  1. To create a New Project, click on the ‘New Project’ button.

  1. Enter Project Name and click on the Create button.

3)Click on the ‘Select a project’ dropdown and select project.

  1. For Enable Google Calendar API, click on ‘+ ENABLES API AND SERVICES’.

  1. In Search Box type ‘Google Calendar API’, it’ll display the “Google Calendar API” as shown in below screenshot & click on the ‘Google Calendar API’ result.

  1. For Enable “Google Calendar API”, click on the ‘Enable’ button.

  1. Click on the ‘CREATE CREDENTIALS’ to Create Credentials.

  1. Fill up all Credentials as shown in below the screenshot.

  1. Click on the ‘What credentials do I need’ Button.

  1. Set up an OAuth Consent Screen.

  1. Fill up all Application Details and click on the “Save” button.

In ‘Authorized redirect URIs’, add a full URI to the ‘saveGoogleApiKey’ Entry Point.

Example: http://your-domin.com/index.php?entryPoint=saveGoogleApiKey

  1. Click on the “Refresh” Button to Create oAuth Client Id.

Download JSON Credentials file.

  1. In Google Calendar Settings, upload credentials JSON file. And click on the Save button.

  1. Click on Profile Link.

  1. Open User Profile, go to Advanced tab.

  1. Go to the Google Account Synchronization section. Enable Google Sync and Click on the Authorize button.

I hope it helps you

5 Likes

Thanks for this great tutorial!

1 Like

I have followed this tutorial, many times, no errors are thrown but I still can’t get to “Current API Token is configured” is still shows as “UNCONFIGURED”

Please help - I have tried everything.

Some additional detail. I am running off a local server using WAMP. My redirect is to http://localhost/suiteCRM/etc

After I step through the configuration is redirects to a blank page.

Great explanation Urvi, i hope this goes into the Docs too.
@p.konetskiy @Mac-Rae

1 Like

I have followed your tutorial, step by step, multiple times and it still does not work :frowning:

what step is not working, can you please share with detail so i can help you to resolve

1 Like

I do all the steps, generate an authentication, upload the JSON file etc - no problems. I go to the user profile and step through all the details to link the accounts, but on completion it ends at a blanks screen (i.e. the final redirect page is not working) and the token authentication icon still shows as not authenticated.

It is the page that starts with this URL: http://localhost/suitecrm/index.php?entryPoint=saveGoogleApiKey&code= etc etc

It is pointing to the correct location for the file but the page is not responding. I have error reporting turned on with my web server and no error is being thrown to the browser.

Looking at the suitecrm.log file I note the following errors:

Exception handling in … \SuiteCRM\include\MVC\Controller\SugarController.php:400

Exception in Controller: cURL error 60: SSL certificate problem: unable to get local issuer certificate (see https://curl.haxx.se/libcurl/c/libcurl-errors.html)

I updated my php_curl.dll file and have progressed to the stage where I get a Google email indicating SuiteCRM is linked to my Calander - but SuiteCRM is still displaying API Token as UNCONFIGURED and no synching is occuring

I had a similar issue with the white page and ended up going back in to the Google API developer console and the URI had been changed to some default address. I added the correct URI with the entryPoint address and was able to authenticate with my gmail address. Now my new problem is no sync after all this. I see in the logs a message about the Calendar bean is missing. I will document it and open a new thread.

What issue are you facing
please share a screenshot
if you still facing same issue

Hi @cherub-chum
Thanks for appreciating my work and approve to update as a Docs
Thanks
Urvi

I am also struggling to get the Google Calender integration to work. I follow the instructions to create a JSON Credentials file on the Google Developer Console.

Then I go to the Admin Google Calendar Settings to upload the credentials JSON file, but everything with a .json extension is greyed out and inaccessible. The files with a .txt extension are accessible in the same folder.

What is going on?

Hi,
Here is explained step wise step creation and installation of JSON keys.

2 Likes