Gmail does not show incomming mail bug


I am trying to add gmail on suitecrm.
I am using turnkey suitecrm on Proxmox and upgraded suitecrm to:
Version 7.12.4 Sugar Version 6.5.25 (Build 344)

I can connect to gmail and send test mail but when I go to emails I don’t get to see incoming emails.
However I discovered that when I go to emails, a small grey rectangular icon appears and disappears on the right very fast. I tried this in Opera, Chrome, Firefox and Edge.

When I refresh the page and click very fast on that icon I can manage to click on it and then I get the option to select the email box (gmail).
Selecting the email box makes me see the emails.

So everything seems to work but not “out of the box”.

Is this a bug or do I have to change somewhere a setting?

With kind regards,


Hi @Tao-Lee ,
Can you share a screenshot of your inbound email setting or email setting

Inbound Email Setting

Email Setting

and please enable in email setting “Users may send as this account’s identity:

Hi Vijay,


I don’t see: Users may send as this account’s identity

You’ve created a bounce handling account. Go back to the list view and press the create inbound email account, not create bounce handling account :+1:

Thanks Mac-Rae!
That did the trick