Getting an "Exports Disabled" message despite the user role allowing Exports

So I am trying to allow users to export their leads, so I gave all roles export rights and set them to “All” in role management.

When I log in with their account and try to export, I get an “exports disabled” message, and when selecting them in the Leads List View, instead of it saying “Bulk Action” like in my admin account, it says Email by default and then I have to click to “Export” which still ultimately fails.

The only way I can get exports for other users to work is to temporarily make them system admins in user settings, but obviously that is not a good long term solution.

What is making “Exports Disabled” despite giving them export permissions in Role Management. Is there something I am missing entirely? Thanks.

Are the leads assigned to the same security group as the Users?

In each Lead detail view, scroll down to the bottom and assign Security Group.

If that works to solve your problem, you can Mass Assign the group to many Leads at once, or all.

Yeah the leads are the same security group as the user so unfortunately that wasnt the problem

I don’t know, then. Maybe just check both your logs at the time of the Export attempt, to see if you find any clues.

If that doesn’t help, I would try reaching out to the Security Settings author on the SuiteCRM Store. Even though (to my knowledge) you didn’t pay for the Pro version, he might help you and I guess he will appreciate the chance to correct any bugs, if in fact they exist.


  1. Try Admin->Quick Repair & Rebuild-> Repair Roles, ask that user to re-login to CRM
  2. Wild guess, can you check if that user have multiple groups and that might be conflicting each other.

Thanks for the reply. I did the repairs, they are in only one group, and still isnt working. The only “solution” is still to give them administrative access.

In this case, I believe SuiteCRM.log and apache log may help you to identify the issue.

thats unfortunate as i am gonna have no clue as to what i am reading but ill see them now.

I couldnt edit my other post but this is all that came up in todays log

Mon Sep 18 13:48:00 2017 [31418][-none-][FATAL] SECURITY: User authentication for fmure failed
Mon Sep 18 13:48:00 2017 [31418][-none-][FATAL] FAILED LOGIN:attempts[1] - fmure
Mon Sep 18 13:48:08 2017 [31438][-none-][FATAL] SECURITY: User authentication for fmure failed
Mon Sep 18 13:48:08 2017 [31438][-none-][FATAL] FAILED LOGIN:attempts[1] - fmure
Mon Sep 18 13:48:22 2017 [31479][-none-][FATAL] SECURITY: User authentication for fmure failed
Mon Sep 18 13:48:23 2017 [31479][-none-][FATAL] FAILED LOGIN:attempts[1] - fmure

Which obviously has nothing to do with the export issue, as fmure is not the account I am running the exports on

I forgot to ask you one more possibility, Can you check Admin->Locale->Admin export only ?

This may help you.


I feel extremely stupid. Thank you for your time to help me out. Cant believe it was as something as simple as a check box I missed lol. I appreciate it.


Just check admin - locale settings