Get "Import Errors Occurred" after 100 records while importing contacts

[SuiteCRM 7.3]

This is very strange as I have a sandbox SuiteCRM system set up and it imports the entire 4500 contact records without errors from the exact same csv file.
This would indicate my import file is formatted and mapped correctly.

If I try to import the first 300 contacts on our production system, SuiteCRM stops importing after 100 records with an “Import Errors Occurred” box (see attached). I click ok and I see 100 records have been imported correctly.

If I then try to import records 200-400 it only imports the first 100 records and produces the same error. I check and sure enough an additional 100 records were imported correctly.

When I watch the progress bar on the sandbox as it imports… I see it increment in 100 record blocks…
…but for some reason I can’t seem to import more than 100 records on our production system.

I compared all the settings I could find: upload size, log size, timeouts and could not find any differences.

Thanks for sharing any suggestions you may have!.

After a number of hours looking through various parameters in config files I actually found the following parameters in config.php:


I made ‘import_max_execution_time’ => 3600
I made ‘import_max_records_per_file’ => 5000
I made ‘import_max_records_total_limit’ => ’ ’ // (unlimited)

After these changes and since I had to import less than 5000 records it worked fine. It was a happy day.

I hope this helps a few others…


Huge help…can’t thank you enough!!