Generate Letter

When I go to Generate Letter under Account, Contact or Lead I get ERROR No template found, Please go to PDF Template Module and create one. I Have created two templates for each one and still get the error. I dont use the quote, invoice and product modules however I went there and created two templates for quotes and invoices and when I go to a quote and click Print PDF it brings up the two templates and when I pick one it downloads it, same with invoices.

Does anyone have any thoughts on this please



Have you created a PDF with type ‘Contact’? Otherwise you won’t be able to use the Generate Letter functionality.



yes I have created two contact and two account letter templates under PDF template and I get the same error on both account generate letter and contact generate letter.


I have installed 5 different sites with different configs and here is where im at.

If I use mysql with php5.5 then generate letters seem to work fine but when I add a field to contacts it saves sometime and sometimes not. I have to do it many times for it to work and even after I have it I look at it once in contact then when I go back to studio and make another change then go back to contacts it disappears.

I am unable to install sqlserver with php 5.5 because php 5.5 isnt set up for sql server support. Im trying to get the hosting company to fix that.

If I install the site with sql server and php 5.4 i get the error no template found when I generate letters

lastly if I use mysql and php5.4 both the generate letter works and the studio changes seem to stay as they should.

Each and every install even using php 5.3 has your installer checking and saying that everything is compatible and continues the install. It doesnt error and tell me which php version to use.

exactly which php version should we be using for 7.14. This is driving me a bit crazy


I have tried to generate a letter on php version 5.2, 5.3, 5.4, all give the same error with sql server. I currently have the hosting company looking into this. Workds great on mysql.

Of course im still not sure what version of PHP I should be using.

Hello I have the same problem. Has anyone got a solution to this bug?