Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Gateway Time-out

Hi, I’m updating suite from 7.2 beta 3 to 7.2 but i recive this error:

Gateway Time-out

The gateway did not receive a timely response from the upstream server or application.

Any idea?
thanks

Sounds like a timeout. How long did the page load for? What is the timeout set to on your web server?

Thanks,

Will.

The server here threw the same error.

Found the cause and the solution - on my server.

( Unrelated site note: you are probably running a reverse proxy in front of Apache. )

Submitted pull request.

https://github.com/salesagility/SuiteCRM/pull/137

You can fix your server. Edit .htaccess by hand.

Find “+FollowSymLinks” and replace with “+SymLinksIfOwnerMatch”

Save.

Reload the page.

It should work now.

Post back with your results.

ChrisC, I have not solved.
my timeout is 30sec.

Try this:

Add the following PHP configuration directives to your .htaccess file:


php_value memory_limit 80M
php_value post_max_size 75M
php_value upload_max_filesize 75M
php_value max_execution_time 601
php_value timeout 601

# PHP 5, Apache 1 and 2.
#<IfModule mod_php5.c>
php_value magic_quotes_gpc 0
php_value register_globals 0
php_value session.auto_start 0
php_value mbstring.http_input pass
php_value mbstring.http_output pass
php_value mbstring.encoding_translation 0
php_value memory_limit 128M
php_value post_max_size 75M
php_value upload_max_filesize 75M
php_value max_execution_time 601
php_value timeout 601
#</IfModule>

For more performance on large systems you can…

Edit the file “config_override.php”

The below configuration options should improve the performance of your SugarCRM installation, but may change the way some of the front-end looks. For a detailed explanation of the below configuration options, please see SugarCRM’s Performance Tweaks page.

http://support.sugarcrm.com/02_Documentation/04_Sugar_Developer/Sugar_Developer_Guide_6.5/02_Application_Framework/Performance/General_Performance_Tweaks/

Add the following SugarCRM configuration options to your config_override.php file:


$sugar_config['disable_count_query'] = true;
$sugar_config['disable_vcr'] = true;
$sugar_config['hide_subpanels'] = true;
$sugar_config['hide_subpanels_on_login'] = true;
$sugar_config['save_query'] = 'populate_only';
$sugar_config['verify_client_ip'] = false;

Nothing.
Can i update manualy?

I can not increase the server timeout.
Can i do a manually update? How?

Thanks.

Hello there.
Have the same issue here.
Running the Suite CRM here locally in the office on a virtualmin box, and yes. I have the same issue. :frowning:

Any ideas when the change doesn´t work?
Replace +FollowSymLinks with +SymLinksIfOwnerMatch
Any idea for virtualmin users?
Hoping to hear from you.
Regards,
Paco

reinstall everything?!

Hello.
Nope just solved it :wink:

Log in to your instance -> admin -> Repair -> Reconstruir archivo .htaccess (reconstruct .htaccess file)
Once clicked on this it solved me the issue…

thanks
regards,
Paco