Fresh Install 8.5 - Shared Hosting + no CLI access

Hi, I see there are others having these issues but I couldn’t find one with my situation.

I am on a shared hosting webserver. I have create a mySQL database and user (and I’m 100% sure I’m correct in this part tested using mysql workbench to connect). I have no tables in it.

I go to and get the install page. I keep getting Database Connection Error: The provided database hostname, port, username, and/or password is invalid.

(unfortunately due to forum rules i can only post 2 links per post as a new user, so below may look ugly)

Things I have tried:
http s ://
http ://

Host Name
ht tps://
ht tp://
localh ost
127.0 .0.1

I assume the admin name/password are “created” and not required to login initially (correct me if im wrong)

I tried to populate with or without demo data.

I’m confident I have the right suitecrm user/password and database name/port.

The only I can’t do is run the file permission command via CLI, however I can do it via ftp if there is a trick to do it that way? I believe the suite folder is set to 755 (I assume that is recursive?)

I believe all the required modules are enabled. (pdo-mysql etc)

Hoping someone could help out! I’m ready to give up.


Your web root should point to the public directory.

After that, you should type public in any URL , or see it there.

You should point your URL to the root of your SuiteCRM installation and see the installer page.

You should not point your URL to the public directory and see the installer page appearing.

Hello, Welcome to the SuiteCRM community! :sparkles: :tada: :confetti_ball:

Did you read this post?

I might be not understanding, but are you saying suitecrm has to be at the root of the server? I am running my business website on the same server so I would not want that if that is the case - or am i miss-understanding?

I do only see the installer page when in the public directory.

I’m not quite sure I understood everything you said, hoping you could explain differently.

Yes - it’s where I started. But because I don’t have access to CLI I can’t use grep to find all the .env files. I also cant use the “find” feature to set the permissions differently. I’ve dangerously set everything to 777 just to test with the same results.

Am I stuck getting a dedicated server for this?

There are some hostings which will give you an honest level of CLI access even without an expensive dedicated server.

I would not attempt to run SuiteCRM without at least the ability to drop to a command-line, grep a log, find a file, etc.

About the web root, a preliminary decision: what is your plan regarding the URL you want to use for your business website, and SuiteCRM website? Is it

Either of those, you need to ensure your web server configuration is making the SuiteCRM URLs go into the public directory as their root, not to the top SuiteCRM directory.

If you’re using Windows system then download and install PuTTY. Then you need your server IP, username and password to access it from this application.

Download PuTTY

@john.lescault You should go into your shared hosting control panel and easily “create a subdomain of your main domain” for the CRM to use exclusively (, your CRM subdomain would run “beside and separately from” your main website (