Forcing CPU limit on shared hosting server

Good day,

I read this post and it’s related and very good, but it’s not quite what my situation is

I’m on a shared host with a limit of 1GB of ram.

Every time I start the upgrade wizard (but only after about 7.10) it puts my cpu usage at 100% and everything stops and i get a 508 error.

Then I have to go into cache/upgrades and delete the stuff in there and after I can get back into the upgrade wizard.

I have tried, I think, pretty much everything and the only two solutions are:

  1. Upgrade my hosting plan to more ram or
  2. somehow impose a limit onto SuiteCRM so that when it does stuff it does not reach the CPU limit.

I was hoping someone could instruct me about a way to impose this limit. I don’t mind if the task takes 3 times as long because I don’t need that much speed and ram for our small usage.

I found this post as well and this seems to be exactly what i’m looking to do. However, this poster doesn’t give detailed instructions about which directory to create this new file. Also the post is 4 years old so I’m concerned maybe it’s not relevant anymore. I am getting desperate and may just stick it in the main directory of the suitecrm install and see what happens.

Any comments on this would be great because surely I"m not the only one running out of RAM on a shared host with suite crm?


I don’t think you’re running out of 1GB RAM, you’re probably just running out of 128MB in your PHP.

Check your php.ini memory_limit setting.

Go in Admin / Diagnostics and select phpinfo. There you can check: your effective memory_limit value, and your php.ini path.

Also increase max_post_size and max_upload_size and max_execution_time, any of these could be causing your issue.

Doh… Somehow I missed your reply to this…

This is what I have in my public_html dir for php.ini

Although it’s kind of ‘over’ now for me (see my other thread for fun and learning) I would like to make sure I’m set up correctly for the next SCRM upgrade.

What do you think of this setup here? Do you think these limits would have caused my pain? And if so, what would you set for these to get the job done but not lock my shared hosting account down?


; Resource Limits ;

max_execution_time = 90
max_input_time = 120
max_input_vars = 1000
memory_limit = 512M

Those look fine to me. Check also max_post_size (or is it post_max_size?) to make it big enough for the upgrade zips also (around 40MB?)

Hmm. Interesting.

Here’s what I’ve got:


; Maximum size of POST data that PHP will accept.
post_max_size = 32M


I wonder if this might have been the cause of my original pain?

Doh! You might be right here. Mine is set to 32M, but I’m looking at the file and it is 32.6M … that … really sucks if that was the problem. HA

I hope someone else reading this on a shared hosts checks these first… my road was a painful road travelled…

If the upgrade is your goal, download it on your local machine, upgrade it on your local then upload it again.

Thanks for your comments, suggestions and feedback.

I assume to do this, you will also need mysql working on the local machine?

It would be great to get a step-by-step for this process to try that idea. Here is what I guess you have to do:

  1. clone the working suite crm directory instance on shared hosting (just in case)
  2. download the cloned version to local machine
  3. [something to do with mysql dabase here?]
  4. perform upgrade wizard steps as desired
  5. upload newly upgraded suitecrm instance from local machine back to shared hosting directory
  6. [something about mysql database here?]
  7. rename directories appropriately
  8. check .htaccess and config.php to make sure all site URL settings, etc are correct (I learned this recently…)

How does that look?