Filter using advanced filter date between start date and end date failed with 7.14 and 8.5

Hi. I have an installation in a dedicated server with the next specs:
Ubuntu 20.04 with PHP 8.2.15 and MySQL Ver 14.14 Dist 5.7.42 and my user has Administrator privileges. I’m trying to filter records from a start date and end date using the Advance Filter but it doesn’t work even if I know for sure that the records have that date. The console log of SuiteCRM show: “[ERROR] convert: Conversion of 2024-01-01<>2024-05-01 from Y-m-s H:i to Y-m-d failed”

Obviously I tried to search for that exact same problem here or Google but it seems that no one has found a solution for that even if implies touching the code. My main concern is that I have installed the 8.5 version and has the exact same behavior but only when it comes to the case of searching between dates which is very common requirement for the users.

I though it was a matter of format conversion or the fact that some date columns has date/time format and the search input only allow dates but even if I put the dates in the same format as the Database or if I add the complete format Y-m-s H:i to the search, the outcome is the same.

Thank you for your help!

Hey @davidmov,

Were you trying on a fresh install? or a customized instance?

Did try with 8.6.0? there were some fixes on this release related with dates.

From 8.6.0 Release Notes - Bug Fixes

  • PR: Fix #399 - Error on Date Component in Filter Mode

Also on the suite v8 demo site the date filter “is between” looks ok

Hi… Fresh install. No I haven’t tried 8.6 but I will today and will share the results. Thanks

I wish I haven’t done that… the update script deleted my backups (which I didn’t knew that if I have those in my root folder, the script delete all folders existing in that or I don’t have any other explanation) and since I can’t go back to the way my installation was, I have to keep the 8.6.0 version but now my entire instance crashed once I install the spanish language for the new version and now my site looks like the picture and there is no error in any log nor PHP or Suitecrm log is working and I’m losing my mind here.

Fixed disabling the new language in the config.php or config_override.php. Still, weird behavior of the ./bin/console script to deleted my backup folders. Lesson learned.

But I’m still having the same issue with the between dates in this new version:

Perhaps the reason that this works normally in the demo is due the date format which in this country is commonly used the dd/mm/yyyy format?

Hey @davidmov,

Wasn’t able to look into this earlier…

This might be a core bug, needs some more investigation.

Best to create an issue in SuiteCRM-Core

1 Like