Falling at the first hurdle...

Trying to install 7.10 on my server, upload of all files and changing permissions went fine, on running install.php my server passes all requirements, the log in to the MySQL database is accepted - then nothing happens, no tables are created.

These are the last lines in install.log:

Begin DB Check Process *************
2018-11-13 12:13:45…testing with mysql:mysqli
2018-11-13 12:13:45…Basic form info is valid, continuing Process.
2018-11-13 12:13:45…Testing user account…
2018-11-13 12:13:45…Connection made using host: localhost, usr: suitecrmadmin
2018-11-13 12:13:45…SUCCESS:: no errors detected!
2018-11-13 12:13:45…End DB Check Process *************
2018-11-13 12:13:45…installerHook: Info: custom/install/install_hooks.php not present, no custom hooks to execute
2018-11-13 12:13:45…calling handleSugarConfig()
2018-11-13 12:13:45…calling handleHtaccess()
2018-11-13 12:13:45…calling handleDbCreateDatabase()

Then the install just hangs.

Tried it a few times, even deleted and recreated the database, changed database username and password but with same result.

What should I look at next?

Hi, welcome!

You should look at your logs to gather more information about the error.

I would guess that your web server log (usually called php_erorrs.log or errors.log, it’s defined in your php.ini) has a FATAL error due to the insufficiency of one of these PHP parameters:

memory_limit (make it 512 MB if possible, or at least 256MB)

all of these normally need to be increased from defaults.

Got my hosting provider to check all those parameters, but the install is still failing to create the tables. Install,log shows:

2018-11-15 14:07:36…testing with mysql:mysqli
2018-11-15 14:07:36…Basic form info is valid, continuing Process.
2018-11-15 14:07:36…Testing user account…
2018-11-15 14:07:36…Connection made using host: localhost, usr: suitecrmadmin
2018-11-15 14:07:36…SUCCESS:: no errors detected!
2018-11-15 14:07:36…End DB Check Process *************
2018-11-15 14:07:36…installerHook: Info: custom/install/install_hooks.php not present, no custom hooks to execute
2018-11-15 14:07:36…calling handleSugarConfig()
2018-11-15 14:07:36…calling handleHtaccess()
2018-11-15 14:07:36…calling handleDbCreateDatabase()

Then no further progress.

Any thing else I can check?

  1. Anything in the web server log?

  2. Did you set correct file ownership and permissions?

  3. Did you previously create a database for SuiteCRM? You shouldn’t, you should let the installer create it for you.

I tried deleting the database and re-ran the install, but it complained that the suitecrm database did not exist.

I also noticed that the file config_override.php was missing.

My hosting provider says everything else appears OK.

I am baffled by this - I have installed hundreds of SuiteCRM’s, all versions, and I never create the database first.

Which versions are you running of

  • SuiteCRM
  • PHP
  • database

Not having a config_override.php at this point is normal, the installer creates it near the end of the installation.

SuiteCRM 7.10.10
PHP 7.2.12
MySQL 5.5.42

I assume this is Linux.

Do you have SSH access to your server?

If so, what does this command give you on the SuiteCRM main directory?

ls -al

Please paste the results here so I can look at your ownerships and permissions.

Can you find a suitecrm.log in that directory?

Can you read your web server error log? It is defined in your php.ini and it is usually called php_errrors.log or errors.log. You might have to ask your hosting about this.

My hosting provider just contacted me to say that he had overlooked the initial chown line in the permissions and that he has just set this with Apache, so I am going to try it again.

I asked my hosting provider to assist with the install and he did a great job! I didn’t ask how he resolved the issues, but I was happy to pay his modest charge for getting the 7.10.10 install up and running.