Facebook Integration Issue


I faced facebook depricated permmission issue, later I changed its core file and changed permission then I start getting following issue.
After verifying facebook account it gives broken page on following callback


following erros are in console

Uncaught ReferenceError: YAHOO is not defined
at sugar_grp_yui_widgets.js:2
dashlets.js:38 Uncaught ReferenceError: SUGAR is not defined
at dashlets.js:38

I am not able to attach file otherwise would have attached file

Apache Version 2.4.29
PHP Version 7.0
MySQL Version 5.6.38
suitecrm 7.9
linux 2.6.32-042stab127.2

If you’re using SuiteCRM 7.9.0, please upgrade to the latest 7.9.12.

You can attach files by putting them here


and images here


Then just give us the link to those.

Thanks for replying.

I have latest version intstalled that is 7.9.12 already.

Please find image

You definitely have permissions issues, your CSS isn’t loading correctly. The site should look very different from that.

The recommended permissions settings are like this:

sudo chown -R www-data:www-data .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload

But before running those commands you must determine if your web-server user is in fact www-data, otherwise you need to adapt that first command.

this happens only after facebook login come to redirect url.

All permission are set already

website’s css is running ok, but this gives problem once i click on facebook login and process retruns to callback url

Please check your config.php if it looks like this:

  'host_name' => 'www.company.org',
  'site_url' => 'http://www.company.org',

I’m trying to check if your URL is well formed.

Yes config is correct as per your recommendation.

I also found a bug “deprecated permission of facebook”. I changed that anf facebook start working but at callback not giving desired ouput.


Please reply ASAP.

I don’t really know this part of SuiteCRM - it is a big app and I never personally used the Facebook integration.

Can you explain exactly what the bug was, and exactly how you fixed it?

Can you please try this on the live demo to see if it works there?


Or if you need admin access, use this one instead:



I checked with admin access and found issue with facebook integration.

check following URL and reply asap.


I resolved above error but after login I still get this screen on your demo site.

Please check.


It also have twitter integration issue.

All testing was done on demo admin site


Ok, if it happens on the admin site, with a clean install, it’s probably a bug.

The next steps would be for you to search GitHub to see if the Issue is already reported, and if not, open it. Your screenshots will be useful.


I already checked github and following issue is reported.Please let me know if this is fixed or not?

see following url f github …


No, it isn’t fixed…

My advice is this: wait for version 7.10 to come out, maybe today or tomorrow. Then wait a few hours for the developers to clean up GitHub from all the issues they closed with 7.10.

THEN post on the Issue saying you have the same problem and asking for resolution, I hope somebody can have a look at it then :slight_smile:

Thank you .