errors when install in Localhost with XAMPP on MAC

Hi, i tried to install SuiteCRM-7.11.8 on my MAC (MacOS Catalina) in localhost using Web Server XAMPP with the latest version which is support PHP 7.3.10.
I have copied SuiteCRM-7.11.8 folder to my htdocs folder and renamed to “SuiteCRM” to make it simpler.

The problem started when i started the apache, mysql, and i tried to run the application on my localhost:8080/SuiteCRM.
When it redirected to http://localhost:8080/SuiteCRM/install.php i got some error message (you can see error message in the attachment) and i search for the solution for a whole day.

I found this thread with similiar error messages
and he said the issues are with user group and owner from local config, but still, it doesn’t give any detail information how to solved this error.

I have tried this command in my terminal at SuiteCRM folder inside htdocs: (source from

all of the command is running except the sudo chown -R www-data:www-data .
but the response from terminal is: chown: www-data: illegal group name

When i run
ps aux | egrep ‘(apache|httpd)’

the result is: calvinsugianto 11846 0.0 0.0 4258876 248 s000 R+ 11:25PM 0:00.00 egrep (apache|httpd)

So i tried to sudo chown -R calvinsugianto:calvinsugianto .
but still give same result:
chown: calvinsugianto: illegal group name

I just need to use it in my localhost for a while anyway, but i lost direction to figure out this issue.
Can anyone give solution for this?


I have tried to install SuiteCRM on windows 10 but the error still appear with the exactly same error message, it is very weird though in windows 10, there is an error “MAC OS”

I have no idea how to implement SuiteCRM if i can’t install it in Windows and MAC environment. Can anyone please help me how to install the SuiteCRM ?

You might need to see which Group your User belong to. Run following in shell to see which groups calvinsugianto belongs to

id -Gn

There might be several groups but ignore the groups. I would suggest that if there is STAFF group, then you should do

 sudo chown -R calvinsugianto:staff

Secondly i would suggest to Disable PHP Error display and check your php_error.log file for Error Details. Make sure you have the Recommended PHP extensions installed on your system.

PS: I use MAMP on my MAC which is very reliable.

yes, there is a staff group and i have tried to use this command

sudo chown -R calvinsugianto:staff .

but still, operation not permitted.

I also have tried to set display_error to off in php.ini, but still no effect


Hello Calvin,
have you solved the problem, I have the issue installing SuiteCRM on XAMPP on my OSX Mojave

nope, i’m using YetiForce now instead of SuiteCRM because no one can help me to install SuiteCRM.