Error with campaign assistant

Hello everybody, i am currently enforcing some steadily growing marketing assaults, and i use Suite CRM to do that. Now, as you come open the assistant for campaign creation and - management, at the point where you need to set a start date for your email campaign to begin sending the chosen email template, you can choose a date with the dropdown menu, which shows a little calendar or type a date in by yourself.
So if you do that, and try to continue with “Next” button, the same screen appears again, exept that there is a red warning, that says : no startdate set!

But you just set it! I tried many ways of fixing this issue by alternative ways of inputs, but theres always the error message.
And at the end of the assistant, at the summary of the campaign - content etc, theres always a red marker for not filling out a start date. You can see this at the pictures i attached, and i hope that someone can help me fix this, because with this issue being an impeding thing, you can only do a little workaround, with aborting the assistant and then send the email content out with the campaign details context button at the left upper side. This is kinda bit weird and strange, cause it also seems that this is not the intended way to send out campaing emails - theres few to no confirmation that you really sent the mail but that is only an illusion i guess and not the main problem.

Thank you in advance and have a nice day!
Felix R. from Munich, Germany

Thank you for your help, and look at the error at picture …4_4.! and following


Are you currently still experiencing this issue?

If so, would you be able to detail which Version of SuiteCRM you’re experiencing it on?

I am currently unable to replicate this issue on the most recent version at the moment, (7.7.6), so you may wish to upgrade and see if this resolves the issue.
(if you do upgrade, please make sure to take backups beforehand, and set permissions / run Quick Repair and Rebuild afterwards)


the problem could be the difference in timezone, so you could be setting the date and time of start date which appears to be in the past to suitecrm.

Try making it a day later and see if the problem still persist


Hello and Thank you for your advice- we made an Update from 6.X to 7.2.1 because of some other issues and that was a bit of a blast - but our ServiceGuy for Updates etc made it clear that this is a kinda difficult process, when you want to keep all the saved data like contacts, companies and their attributes and so on.
I am currently trying to convince the head of office to update again ( with proper backup beforehand of course, but because Suite is in daily use and can only be out of service for max 24-48h this is a bit hard to achieve for me as a small apprecntice with high technological understanding compared to the pretty sub-average users in our company. Anyway timezone configurations cannot be the problem because i tried many different dates for a start date, but i will test some more and yes the problem is still occurring.

Thank you for your efforts, this is much appreciated.
Have a nice day!
Felix R. from Munich