Error when creating a new user

Hi, Whenever I try to create a new user and press save nothing happens. When I checked the console inside Chome it says, Admin_check is not defined at HTMLInputElement.onclick.

I checked the log file but nothing of substance inside. I have SuiteCRM 7.9.11.

Any help is welcomed.

Thank you

Is this a new installation?

Is it working well, except for this issue?

Can you share some more details? OS version, PHP version?

No, it is not actually, been using it for some time now. I am using it on Ubuntu 16 with PHP version 7.
I have the same issue when i try to create a new account too. Any idea as to what might be the cause of this ?

Perhaps you could try an upgrade to the latest in your 7.9.x branch? There have been many releases since your version, maybe the bug is already fixed…

Also, did you check your web server log file php_errors.log?

If there are PHP errors that SuiteCRM doesn’t catch, that’s where you’ll find them.

This might stupid but, I cannot find the said log in the root folder, is it located somewhere else?

Thank you

Check your php.ini, you can enable the log and define where it is located. I usually place it in the SuiteCRM root directory.

Restart your web browser and it should start working.

So I did upgrade to Version 7.10.4 and I still have the same error. I have found the log file but it does not specify anything about the said error. Anything other thing I can check?

I also have another server running Version 7.8.18 everything seems fine with it

Thank you

Why 7.10.4? Can’t you go directly to the latest 7.10.9? There are many fixes since 7.10.4.

Apply this little patch after the upgrade:

https://github.com/salesagility/SuiteCRM/pull/6371/files

I am encountering the exact same issue after a fresh install of SuiteCRM 7.11.15

So far everything else seems to work correctly but in the admin panel I often face this issue. Specifically when creating a new issue, when I press the save button nothing happens and in the browser console the following message appears:

index.php?module=Users&action=EditView&return_module=Users&return_action=DetailView:4998 Uncaught ReferenceError: Admin_check is not defined
at HTMLInputElement.onclick (index.php?module=Users&action=EditView&return_module=Users&return_action=DetailView:4998).

NOTE:
In my case, I was using the Catalan language when loging in as adminsitrator. As soon as I logged in with english language it all worked correctly. I guess there is some issue with the language.

The problem with: “Admin_check is not defined” is in the Catalan translation. You can modify the file “modules/Users/language/ca_ES.lang.php” and search for “LBL_CONFIRM_REGULAR_USER”. Change the line with this:
‘LBL_CONFIRM_REGULAR_USER’ => 'Ha canviat el tipus d\\\'usuari de l\\\'administrador del sistema usuari a usuari regular. Després de guardar aquest canvi, l\\\'usuari ja no tindrà privilegis d\\\'administrador del sistema.\n\nFeu clic a D\\\‘acord per continuar.\nFeu clic a Cancel·la per tornar al registre.’,
(Three backslashes on each tilde)

1 Like