Error when creating a new user SuiteCRM version 7.11.18

When creating a new user, an email is automatically sent to them with their username and a temporary password, which the user must change upon logging into the CRM. The problem lies in the address received by the new user in the email, which points to another CRM that is incorrect.

We created a CRM for them from a stable copy we have. For example, the original is called ‘’ and the new client’s is, for instance, ‘’.

In the email received by the new user from the new client, it has the following format:
Username: new user
Password: 1234566
Link: (It should say:

Therefore, we need to change the address to which the email is pointing, but we don’t know which file the code is modified from, as the CRM does not allow us to edit these addresses.

Where it says “Publication Address(Dirección de publicación),” “Search Address(Direccion de búsqueda)” and “iCal Integration Link(iCal enlace de integración)” is where the addresses of the new domain should be displayed, but it doesn’t allow editing.

Attached are images for reference:

I think you need to the email settings under admin dashboard.

Thank you for getting back to me. I did access the Email sections, but it doesn’t let me modify the link that is added in the body of the email sent to the new user. I’m not sure if it’s created automatically or if it’s stored somewhere in a code file for modification. In the Email sections, there’s no indication of what it sends anywhere.

For example, this is how I receive the notification email for a new user, with the temporary password that I need to change when logging in for the first time to the CRM. However, as seen in the image, there’s a link to the CRM path where I should log in, but it’s incorrect; it should say, for instance, “” That’s what I need to modify, and it’s not allowing me to do so either from the user view or the Email view.

You could try to find it in the code.

Line 444:

1 Like

Thank you very much rsp for your response and for helping me find this file. Now I’ll check it against the one I have!, I’ll let you know if it worked after trying it out.

Look at site_url in the file config.php or config_override.php.

1 Like

Hi, I’ve tried modifying the files config.php, config_si.php, en_us.lang.php, and es_es.lang.php. After the modifications, I performed a ‘quick repair and rebuild,’ but when creating a new user, I still receive the URL of the original CRM in the email instead of the new one.

  1. Clear Cache: Try clearing the SuiteCRM cache. This will force the system to reload the email template and potentially resolve the issue. You can find instructions on clearing the cache in the SuiteCRM documentation ( You could also run these commands from the command line, inside your bitnami docker container:
cd /opt/bitnami/suitecrm
rm -R cache/smarty/*
  1. Update Email Settings: Access the Email settings under the admin dashboard. Look for options related to “Email Address” or “Publication Address” (depending on your language settings). Make sure these fields are updated with your new SuiteCRM URL.

  2. Again create a new user, verify the email automatically sent to them contains the correct address.

1 Like