Error upgrading SuiteCRM-Upgrade-6.5.x-to-7.0.1

Hi i got the following error when upgrading my sugarCRM 6.5.16 using the SuiteCRM-Upgrade-6.5.x-to-7.0.1 package.

the suitecrm installation works great but the interfaces for some modules are using the old sugarcrm skins and some some like the campaign module look great with your new skin/theme.

this is the warning i got during installation. i also further applied the SuiteCRM-Upgrade-7.0.x-to-7.0.1 by the way.

Warning: include_once(/home/user/public_html/sugar/sugar) [function.include-once]: failed to open stream: No such file or directory in /home/user/public_html/sugar/sugar/include/SubPanel/SubPanelDefinitions.php on line 499

Warning: include_once() [function.include]: Failed opening ‘’ for inclusion (include_path=’/home/user/public_html/sugar/sugar:/home/user/public_html/sugar/sugar/include/…:.:/usr/lib/php:/usr/local/lib/php’) in /home/user/public_html/sugar/sugar/include/SubPanel/SubPanelDefinitions.php on line 499

Fatal error: Class name must be a valid object or a string in /home/user/public_html/sugar/sugar/include/SubPanel/SubPanelDefinitions.php on line 500

any help is much appreciated

Hi there,

Have you set the following recommended permissions on your instance:

sudo chown -R www-data:www-data .

sudo chmod -R 755 .

sudo chmod -R 775 cache custom modules themes data upload config_override.php




thanks. it worked

I have just run the upgrade from Sugar6.5 to SuiteCRM7.0.1. I already had OpenSales and SecuritySuite 6.5.14 installed on the Sugar6.5.

I made the changes you advised below and ran the upgrade. I got two problems. Firstly it said “Error:Query limit of 1000 reached for Upgrade Wizard module”. Then secondly, it complained that SecuritySuite needs to be upgraded to 6.5.14 which is strange as it was 6.5.14 before I started.

Can you help please.

Also I have tried the Googlemaps Geocodeing test but I get a blank screen. I have checked that the CRM server can get out to the Internet and hit Google. Is there some other configuration thing I need to do?

Hi there,

You need to modify your default query limit in your php.ini file to allow the query to execute. Something in the region of 5000-10000.

To address the issue with your security suite version you need to modify/add the following lines to your config.php:

‘securitysuite_additive’ => true,
‘securitysuite_filter_user_list’ => false,
‘securitysuite_inherit_assigned’ => true,
‘securitysuite_inherit_creator’ => true,
‘securitysuite_inherit_parent’ => true,
‘securitysuite_popup_select’ => false,
‘securitysuite_strict_rights’ => false,
‘securitysuite_user_popup’ => true,
‘securitysuite_user_role_precedence’ => true,
‘securitysuite_version’ => ‘6.5.16’,



I can’t find anything called query limit in the php.ini file

Also i have now checked the menus between the demo version of SuiteCRM and my new SuiteCRM and i appear to be missing loads of stuff from the MORE section. All the MAPS items are missing and so is the Reports item. I checked the Module loader and JJWGoogleMaps is not present and nor is Report anything

Hi there,

Please navigate to Admin -> Repair. Click on the Quick Repair & Rebuild link and once it finishes running, scroll to the bottom of the page and click the “Execute” button.

It seems that your upgrade has failed/not run correctly.



I have done the repair but it is still not right. All the Map items in the MORE section of the menus are missing and so is Reports.

JJWGooglemaps still not showing in the module loader.

I have tried rebooting the server. Should I uninstall the SuiteCRM and install a fresh copy from scratch. Problem is I will lose my test data.