Error updating suiteCRM - Leads and Custom Modules

Hello, I was wondering if someone could help me with the following problem.

Context: I have been trying in many ways to update suiteCRM 8.2.3 to version 8.5.1. Upon updating, everything seems to complete correctly without any errors. But the problem is the following: in the previous version, we had modules called Activity Type, VAT Condition, locality, and also the Spanish language pack. When the update is done, it does not recognize the Spanish package, so I reload it, log out, and log back in, and the change is applied.

The specific problem arises when I test the Leads module, where I get errors regarding field validation when I try to load a record. These fields have values that come from the Activity Type, VAT Condition, and locality modules. The files where I get errors come, according to the console message, from the “dist” folder. The mentioned files are of the type “dist_core_fesm2022_core_msj-…” and “node_modules_rxjs…” file. I don’t know how to fix them.

In one attempt, once I loaded the language pack and an Activity Type module package, it worked, as if some “dist” file had been reset or something, and then I was able to load a lead. But later, in another update attempt, that no longer worked.

Honestly, I’m left with the phrase, “it didn’t work, why didn’t it work? it works, why does it work?”. I am attaching an image of the error the console returns. I am asking for help because I don’t know what could be causing it.


That looks like a bug, it’s best to open a new issue for it on Github, for the team to examine.

1 Like

Hi, My team leader found where the error occurs in the system log. It turns out that the error happens when the Email field is set as a required field. Removing the requirement allows the creation of a new lead without any problem. In the end, it was not an error with the custom modules. However, the mentioned field cannot be set as required.

1 Like