Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Error SMTP utilizando Google Workspace

Hola.
Ayer instalé la plataforma en mi servidor.
Nosotros utilizamos hosting propio, pero los servicios de correos son manejados con Google Workspace.
Cuando configuro el servidor SMTP para google (smtp.gmail.com) y con la seguridad y puerto indicados (STARTTLS) Y 587, no hay caso.
Por algún motivo me lleva a consultar a mi servidor de hosting por el acceso y no a gmail.
Verifiqué si podía ser algún problema de mi zona DNS y está todo bien configurado a nivel de spf, dkim, mx, etc.
No se como poder agregar el verify peer name y otros a phpmailer en vendors.
No encuentro las líneas donde poder forzar ello en la clase de phpMailer (SMTP.php).
En gmail está habilitado el “TURN ON less secure apps” para la cuenta que estamos utilizando.
Quedo agradecido de sus comentarios y apoyo.
Saludos desde Chile.

Creo que tendrás que hablar con tu hosting para ver dónde puede estar el problema. Nosotros utilizamos intensivamente cuentas Gmail de Google Workspace configuradas como imap y smtp y funciona correctamente. Funciona incluso en mi instalación local de desarrollo donde ni siquiera tengo https. Si tienes acceso a los logs del SuiteCRM y a los logs del servidor web quizás deberías ver si allí está dejando algo que te pueda dar pistas.

please see this blog