Error on Opening Module - An error has occured: {"content":"


When i try to open a module - any module, I get a window with this error: An error has occurred: {“content”:"

Screenshot is below:

This is not good at all for the user.

I had this issue on a shared host - the shared host actually pulled SuiteCRM from their Softaculous because of this issue.

I installed SuiteCRM on GCP and also encountered the issue.

Please can SuiteCRM make some checks into it, try for a global fix - would it be something to do with a php version?

Is there anything I can do to fix? Does anyone have ideas about a fix other than the workaround of disabling ajax.

Thank you.


just started to get this myself


I get it when trying to view a Product on Desktop Chrome. Android Chrome and Edge are fine.

We haven’t really made any changes to the Product Module and only have a small number of Products.

We’re also getting other issues, which may or may not be related:

  • Some Reports (but not all) containing Product information go blank until the Product is removed.
  • Some Custom Fields are losing their Display name (and substituting the system name).

All very strange. I’ve reinstalled Desktop Chrome with no change. The same issues for colleagues in remote locations.



Version 7.11.4
Sugar Version 6.5.25 (Build 344)


Go to admin,SYSTEM SETTINGS, Configure AJAX User Interface, and set disable this module.


Many thanks. It seems to have worked.

Now to address my other problems, which might or might not be related.


I used to like always disable ajax this way.

Edit config_override.php

and add this line

$sugar_config['disableAjaxUI'] = true;

In my experience, lately these messages about AjaxUI are not really Ajax errors, and I never needed to disable AjaxUI to get anything working with SuiteCRM .

I think that was more of an old thing from SugarCRM days, although I admit even today you might sometimes work around some issue by disabling it, but it really shouldn’t be necessary.


@ pgr Isn’t it related to the filters on list view?

I remember seen an similar issue on V7.10.13. To clear it I used a link you suggested:


I think that’s is the root of the issue.



I think sometimes it’s one root cause, sometimes it’s another.

The AJAX UI is never the root cause, if I am not mistaken.

I got this same error by sorting on a subpanel column which break the query on that subpanel. Thus I could not go back to change the sorting or rest to default so that SuiteCRM can no longer sort on that column but that didn’t worked. So i provided some dummy values in the Query Result set in order to bypass the error and display the full module view and then clicked on the Name column of subpanel to change the Sorting Preference.
Is there any way where user can change the sorting preferences on Subpanels or reset it to their defaults?

index.php?action=index&module=Module&searchFormTab=advanced_search&query=true&clear_query=true is for the Module but not for underlying subpanels.

I don’t know of any way to reset that.

But if you know of a specific list of “steps to reproduce” that bug, I would definitely open an issue on Github for it. It shouldn’t be too hard to make it fail more gracefully - if it can’t sort, just drop the filter automatically instead of breaking the UI for the user…