Error on installation (Upload Max Filesize)


I’ve already setup my LAMP server, installed all necessary PHP modules, changed parameters in /etc/php/8.2/apache2/php.ini to the recommended settings, etc. and then attempted to install SuiteCRM 8.4 using the web installer, which gave an unknown error that was not displayed properly, so I decided to go ahead and try the console installer and ran into the following error:

Here’s the setting in my php.ini file:

I’m not sure what’s happening here, but as you can see I’ve already increased the upload limit to 64MB, yet it’s still presenting me with this error during installation.

After running the web installer, I checked the logs and wasn’t able to find anything, so this is the only error I’ve been able to dig up so far.

Does anyone know what’s going on? What should I do?

Did you remember to restart the web server?

I would advise more the 64M, the upgrade packages have been getting pretty big lately. I would recommend 100M unless you feel that for some reason there is cause for concern in that (if your users misbehave)

I just noticed something important, which is probably the real cause of the problem.

Those settings in etc/php/8.2/apache2/php.ini are for the web server side of SuiteCRM (UI), but when running from command line you should also be editing etc/php/8.2/cli/php.ini

Thank you, I’ll change it there and see if that helps. I’m running into an unknown error with the Web Installer as well, so I thought trying the CLI installer might be better.

Hopefully that is the only error. I’ll let you know if this works.

Sure, I’ll increase it to 100M just in case. And yes, I restarted the web server and the first time I tried this and ran into the error I actually restarted the entire machine. I don’t think my users will misbehave, so that will be fine.

I also tried 10M in case there was an upper limit.

After changing the upload_max_filesize setting in that file, the installation proceeds and appears to complete, but I’m left with no navigation buttons after logging in to the CRM.

I don’t know if it’s related, but when I used the web installer last time I had to go in and change RewriteBase to /legacy/ in the .htaccess file, but that line simply doesn’t exist in that file now.

Thank you!

Edit: Found the logs and something went wrong, this is what they look like:

I can upload the entire log somewhere if need be.

It doesn’t look like SuiteCRM can read and write the files it needs to use. I would double-check ownerships and permissions, if I were you.

First, find out the user name that your Apache is using to run

ps -ef | grep apache

Then apply the chown and chmods that are advised in the installation instructions.

Check if you have SELinux enabled, that would probably require further configuration.

Then make a Quick Repair and Rebuild and try again.

1 Like

I ran the ‘find’ commands in the 8.4 installation instructions and double-checked the permissions before I tried to install anything. I copy/pasted them into a shell script and ran it as sudo in the SuiteCRM directory, then checked (user/group is www-data) and permissions appeared fine.

I’m running LAMP on Debian 12 so no SELinux by default. I’ll double-check the permissions once more though.

Edit: Just checked and the permissions seem fine in the webroot and suitecrm folders.

Check your config.php, the entry default_permissions

Other than that, I don’t know, but you need to figure out what is causing those difficulties renaming files etc.

1 Like