I am getting the following error on my ADVANCED OPENPORTAL SETTINGS page.

Notice : Undefined index: distribution_options in /home4/enigge/public_html/suite-crm/modules/Administration/AOPAdmin.php on line 130

Notice : Undefined index: case_status_changes in /home4/enigge/public_html/suite-crm/modules/Administration/AOPAdmin.php on line 173

Guessing these are related to permissions, I even tried fixing them. This is what I did:

‘default_permissions’ =>
array (
‘dir_mode’ => 1517,
‘file_mode’ => 420,
‘user’ => ‘youruser’, // you must replace with the actual value
‘group’ => ‘yourgroup’, // you must replace with the actual value

Then running the following commmands inside your SuiteCRM directory:

sudo chown -R youruser:yourgroup .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php

Still no luck. Does anyone have any experience with the error?

Hi, welcome to the Community! :tada:

In your php.ini, make sure you turn off display_errors and restart your web server. This will remove messages from screen and prevent breaking the app unnecessarily. You can still track errors in your logs.

About the ownerships: where you’re putting youruser:yourgroup you need to put the actual user name (and group) under which your web server is running. You can find these in Admin / Schedulers, in the crontab instructions at the bottom.