Error calculating Grand Total

Dear all,
We’re running SuiteCRM since version 7.9.x and we upgraded it two years ago to version 7.10.11.
Only recently we start to create invoices and quotes, so we detected that, while playing with Products and Services, there is an error calculating the Grand Total.

Let’s say that we create a product and we assign the value of $1’000.
While creating the invoice, the contract or the quote, we select the product and we give a discount, either in amount or in percentage, let’s say 10% or $100, but the result is that, instead of being calculated as $900, it is calculated as $1’100: the amount of the discount is added on top, instead of being removed from the total.
We also tried to put as the amounts as negative (-100, or -10%), but the result doesn’t change.

Because we are interested in this function, we upgraded to the latest version of the series 7.10, but the problem was not fixed, so we upgraded to the latest 7.12.x, but nothing has changed.

PS: We need to mention that we tried the online demo version 8, and it’s working as it should.

Could you please support?

Hmmm, Can you try out the latest 7.12.x demo (here: and let us know if it too works there.

Are you able to test with using your denominator of choice in case this may be part of it the issue.

Are you getting any browser console errors on the Invoice edit view?

1 Like

thanks for your hint.
First of all, your demo is the same version we are currently running: I created a product “myproduct” for the value of 1’000 USD.
I then created a new invoice I loaded myproduct and I applied 10% discount, and actually in the line “Discount” I can see -100 (this is correct).

This is not happening in our system, how should we debug? Apparently we don’t have any error at all…

Ok, interestingly there are no errors. Just to confirm that when open up the browser console log (this is a nice wee reference to explain how to via different browsers that nothing looks like a warning or error.

Do you have any customisations that we should know about?

Hello Samus-Aran, thanks again for your reply.

I just realized what’s the error, and actually this is something that should be fixed.

In my example I was generic and I was speaking about USD, while actually we are in Switzerland and we use Swiss Francs (ISO → CHF).

The currency symbol for the CHF, as for the USD the symbol is the $ and for the EURO the symbol is the €, for the CHF is the ’ - ’ . This means that the system is just attaching in front of the amounts the symbol of the currency, and for the case of a Discount (that is negative) is actually writing:

’ - ’ (as the CHF currency) ’ - ’ (as the negative sign) $discount_amount.

The double “dash” makes the discount becoming positive, because probably is missing a separator or some kind of escaping while handling the currency symbol.

In fact, if we change the currency to EUR or to USD, the error disappear (both their symbols don’t have any mathematical sense) and the Discount is correctly managed as a “negative” amount.

Is it anything that could be corrected in future releases?


PS: We just fixed writing CHF as symbol for the currency, but this should be considered as a temporary fix.

1 Like

Wow! Thank you for your thorough testing. That has certainly highlighted the problem and agreed, it should be resolved. To help us, can you raise this as a bug on our bug tracker (here: ) and we can take it from there.

1 Like

Hello Samus-Aran,
we opened a ticket.
Thanks again for the support and happy new year.