Error after relationship removed

I have a one-to-one existing relationship, but I need to change it to one-to-many. In suiteCRM we can only delete it then create it once again. But the thing is, after I delete the existing relationship, my listview shows this error. What am I doing wrong? I am using v7.10.10 …

Put this line at your config_override.php

$sugar_config[‘disableAjaxUI’] = true;

can you please explain what this does? because I tried this then now The Page isn’t working.

Sorry i type this , not sure why it was trunacated.

Sometimes Ajax return is problem. In that case we advise to make ajax mode off.

$sugar_config[‘disableAjaxUI’] = true;

Forum is truncating… it is disableAjaxUI to true.

I tried turning off my ajax, my listview now is empty.

$sugar_config = true;

I added this line in config_override.php as you suggested, but then it makes my page not to work.

Maybe is trying to suggest to add the following line:

$sugar_config['disableAjaxUI'] = true;

(If you want to enter code in the forum you have to use the code tag other wise certain portions of what you write will not be displayed, like all what goes inside square brackets).

PS: I am not sure that the suggested solution is the correct one.

Have you set permissions correctly?

Have you checked all your logs to see what is wrong?

Have you run the appropriate Admin rebuilds? (particularly Quick Repair and Rebuild, Rebuild relationships and the javascript/js rebuilds)?

By disabling Ajax you will loose its functionality and, since it was working before there is probably something else that you can do!

To be clear , disabling Ajax is not a permanent solution , it is to just if ajax is causing issue.
In Ajax mode , Suite expects JSON as response from all requests.

Sometimes, some JS print or echo outside of JSON return cause this kind of issue. Disabling Ajax is just instant relief, not a solution.
Disabling Ajax you will lose Ajax functionality which is to improve performance, so only recommended when needed.

Well, by doing it, the error stops showing. My suitecrm log says

Tue Jan 22 02:03:31 2019 [8524][1][FATAL] ERROR: rmdir_recursive(): argument cache/themes/SuiteP/modules is not a file or a dir. 

I have also did the rebuilds the you have suggested but it’s still the same.

I actually have 4 out 6 relationships that I deleted and I experienced no errors until I started deleting the other 2.

Thank you so much for your replies :slight_smile:’s suggestion is quite helpful. Thank you sir. But then, my listview is now blank, the table is gone.

From the error that you shared I am inclined to believe that your permissions are not set correctly.

What is the Operating System of the machine on which SuiteCRM is installed?

Good day Sir Amariussi, I am using Windows10.