Email won't save on create or in edit mode

When creating a lead, I am unable to save an email attached to it. I am allowed to add the email after the initial save by double clicking the field and then saving it. But, when using the edit mode, it does not work.

Could you please provide some screenshots?

So I can try and have a better understanding about what you are asking :slight_smile:

I will walk through the steps.

  1. I create lead
  2. fill out lead information, including email address
  3. save lead
    (At this point all of the information, except for the email, is saved.)

Try using “Edit mode” by clinging on Edit button at top of Lead. Using same steps as above it still does not work.

Edit by double clicking field, It Works, but this adds an extra step.

I am having the same problem when upgrading from 7.6.x to 7.7. To further describe it also will erase an email even if you get it saved using the double click edit mode from the contact page or such. As soon as you use the edit and drill into the contact and change any field it will erase the email address upon saving any change.

  1. If I create a new record with an email address, it saves everything but the email address
  2. If I double click on the email field once saved and add it on the primary contact screen i.e., not via the “edit function” on the contact, it will save
  3. However, if I go back in and change anything i.e. title or such from within the edit function, the email get deleted
  4. Notice also that the select boxes for primary and opt in and out are miss configured this is in both themes the new one and the old
    

I’ve got exactly the same problem. Is there a solution for this?

All the best,
Ramon

So I got it to work after clearing cache. Once I did this it reset and everything works fine now. If you are using chrome right click and select inspect, then mouse over and right click the reload button select empty cache and hard reload on the page that is not saving. Then test to see if that solved it.

1 Like

@Tseward Thank you very much, this worked for me.

I’ve noticed that the email address was also deleted in the “contact” module : after editing a contact form ( in order to update the contact description during a call campaign ), the email address was deleted after saving :frowning: … issue is solved after reseting cache

This is very a important piece of information because you can delete many email addresses without noticing it. So if you upgrade to 7.7.6 it is mandatory to clear the cache ! In my case I’ve updated from 7.7.5 to 7.7.6 ( no problem with 7.7.5)

Thank you again.

I can confirm that I’m having the same issue with Leads and Accounts after upgrading to 7.7.7.

It seemed to be a JavaScript issue, If you clear your web browser cache it seems to work. Unfortunately for myself this wasn’t an option I could rely on. I also changed the value $sugar_config[‘js_custom_version’] in config_overide.php as this changes the request value in the javascript url (and hence doesn’t cache)

If anyone could provide a more elegant resolution, I’d love to hear.

Same thing happens to 7.7.8

Hello,

I am having the same issue when i upgraded my CRM from 7.6.4 to 7.7.8.

Following the above advise i cleared my cache and its working fine now. Question is do i have to do it in every session or once cleared its rectified for that particular browser?

Once the cache is cleared, all should be fine for that given browser.

I have this problem with a fresh install of Version 7.8.2. Clearing cache doesn’t work. It is a custom module i’m using so i think that might have something to do with it. I created a person module and moved the e-mail field to another panel in the edit and detail view layouts.

Having the same problem