Email To: Name not on sent emails

Ever since upgrading to 7.10.8 when we sent a quote by email the To name doesn’t automatically show. Instead of

Name <> 

we get just the

In order the have the name as well we have to delete what is shown by default and select the contact from the account. Then the

Name <> 

is formatted correctly. I have looked for the issue on Github but I don’t see this issue.

Just did an upgrade to 7.10.11 on a test install and this hasn’t changed.


What exactly are your steps to “send a quote by email”?

I’d like to try this from exactly the same place that you are using.

Also tell me about the email account - where is it defined? User profile? Admin / Outbound?

After creating the quote and with the quote open we select Email PDF from the Actions menu. This opens the email client within SuiteCRM.

The email account is defined in Admin/Email Settings with Users can send as themselves checked.

This was the only way I could make sending emails as a user work. All other ways I tried returned errors. I also never found good detailed documentation on all the different email settings so I left it at this setting.

Thank you.

I was able to reproduce.

We would have to search Github for any Issues already description this bug… but currently there are too many, and too disorganized, email issues there.

I think there could be a missing line setting the from name here:

But maybe it should be happening automatically, elsewhere, as the new Email object is instantiated.

There’s plans for a Release soon that is dedicated to fixing Email bugs, let’s hope this helps.