Email Templates Not Editable

Hello, I went on to create a new email template today and came across a graphical issue… See below.

As you can see there is no toolbar and the dragging of the element stays. (if that makes sense)
If I click to edit inside of this text box, nothing is editable.
I have tried and verified the issue on two computers, and I have rebuilt it twice.

Let me know if anyone has seen such issue with the email templates before.


Hi there, what version are you running?

Maybe look at running a composer install and the following repair options in this order;

  1. Repair JS
  2. Rebuild minified
  3. Rebuild JS Grouping
  4. QR&R

Let me know if you have any luck!

Just tried, It didn’t work :frowning:
I am on Version 7.11.18
Sugar Version 6.5.25 (Build 344)

Hmm ok,

Which PHP version are you running?
Are you using apache/nginx/IIS?
What OS are you using?

Currently, I am on PHP 7.4

Whoops, sorry, hit enter too quickly :laughing: I’ve updated the card with a few more questions

Haha you are all good

It is running on a cPanel installation. I’m not sure what OS my hosting company is using however it is running on Apache.

Ok np,

if you jump to this demo link and sign in with;
U: will
P: will

Do you get the same issues?

Nope :confused: works fine.

I thought it might be a caching issue at first as well, I tried it on a couple browsers originally and a second computer.

Could it be a permissions issue? Not sure where to check but when trying to save a email template that I wasn’t able to edit (I just titled it test) this came up.

:point_up: this is probably your problem

1 Like

So I’ve got 2 things to suggests.

  1. PHP 7.4 isn’t officially supported so best to downgrade to 7.3 if able as its been known to cause some minor issues

  2. In the C-panel do you have access to a terminal view? if so run the following commands

  sudo chown -R www-data:www-data .
  sudo chmod -R 755 .
  sudo chmod -R 775 cache custom modules themes data upload
  sudo chmod 775 config_override.php 2>/dev/null

Unfortunately I do not have shell access. Is there any way to do this manually? Otherwise I can reach out to the hosting company and have them enable it.

I’ve always had issues with permission on C-panel, maybe reaching out to the company might work, some are really good with it, others are not, if you pass them the commands and ask them to execute it they might get round to it.

Sounds good. I will send them an email now.
Thank you so much for all of your help.

I apologize for not updating the thread. This solution worked. Thank you very much! I appreciate it!

1 Like

Hello @Mac-Rae ,

I have the same issue.