Email templates after the change will not be saved!


after the update to 7.9.12, the changed email templates are no longer saved, but even with a new template, no success.

When I create a new template and click Save, all text and images are deleted and a blank page saved.

I carried out various repairs and no success. :frowning: :ohmy:
Maybe you have an idea.
Many thanks in advance

I just tried this on the online demo and it worked.

Did you change anything in the editor options? (mozaik, tinymce, etc?)

What is your version of PHP?

What errors do you see in your logs at that time?

Thank you for your reply.

I tried all 3 editor Options,but with all the same problem.

PHP version is 7.2, but I also tried with 5.6 or 7


Have you tried it on the demo? It’s better if you try it, that way you can make sure you’re doing the exact same things as in your system.

If the problem is only in your system, you’ll have to do some more diagnostic work. Check your permissions and your logs to see if you can find me some clues! :slight_smile:

Do you mean demo on the of Suitecrm? yes I saw. Everything goes well there
on which folder should I check the permissions?

The recommended permissions settings are like this:

sudo chown -R www-data:www-data .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload

But before running those commands you must determine if your web-server user is in fact www-data, otherwise you need to adapt that first command.

Unfortunately, I do not know where to change the data. I am a customer of Strato.

I saved a text over database and it is shown.

but normal about crm does not work.

Looking at the directory listing image you posted before, I see some folder are owned by “cmpdfe” and some files are owned by “adfrw”.

This can be causing your troubles. Is one of those a group, and the other one a member of it? Which one is which?

And in any case, your permissions 755 and 644 are not very permissive for group access. So you really need to change either the ownership or the permissions.

If you don’t know how to do this, please ask your hosting to do it for you. Give them the instructions I gave you above.

I asked at my hostin (strato). I have no own server and must change everything via ftp. Would you please tell me in which folders should I change the permissions? or should I put all files on 755?

Don’t they give you a SSH shell in CPanel? I don’t think you will go far with setting permissions in FTP unless it let’s you change an entire subtree in one command.

The permissions I gave you above in the commands i listed: all folders 755, some special folders 775 (cache upload etc)

But this is all meaningless without file ownership. There is no practical difference between 755 and 775 if you’re accessing as the owner. And I see you probably have problems with ownership, from your listings, because I see two users. Which one is your web server user? What is the relationship between those two users, in terms of group membership?

Linux permissions are a conjunction of these things, it makes no sense to talk of them independently.

thanks for your suggestions, but apparently it is an old problem that has not been resolved yet.

see for yourself here:

Ok, great, but I still suspect your set up isn’t correct at all. If you run into a lot of problem all over the app, and see a lot buttons and labels showing “undefined”, then you can be sure you have permissions problems.

I have reinstalled the whole program. now only 1 paragraph is saved, the rest is deleted again.

I still fight with the blank email template and can not find a solution.
I see in DB the text is saved only HTML does not.

Do you still get this error you posted above?

If so, what exaclty are the steps to reproduce it?


yes still the same.

I create a new email template.
After saving everything is lost.
Even if I edit an existing email template, the content will disappear
please look at the Pictures

thank you


I have something new to this case.

The existing system email templates do not work either.

I tried “Forgot Password email”, but unfortunately I get this message:

"No email template is selected for the email containing the password that will be sent to the user. Please select an email template in the Password Management page. "

I have “Forgot Password email” in my email templates and also in database. it’s all right

Thank you

Ok, can you please post a new Issue on Github with this? your screenshots will be very helpful. Don’t forget to include that one with the error message.

Thanks a lot for reporting this.

I instaled Suitecrm 7.10 and everything goes great.
Many errors are fixed in update 7.10.2

Suitecrm is getting better and more fun to work

1 Like