Email Template image keeps changing the path for the image to a relative path

Hi, wondering if someone can help. When I am editing an email template, I want to add an image to the template. When I put in the image URL say “https://somewhere.com/image.jpg” the path immediately changes to be “…/…/image.jpg”.

How can I prevent this from happening? I want to have the full URL path I type in stay the same as I type in?

I’m using suiteCRM version Version 7.11.20 thanks.

Just tried with version 7.10.27 by carrying out the following:

  1. Click on ‘Create Email Template’
  2. Select one of the editable body elements where we have Lorem Ipsum etc
  3. Select Insert/Edit image, and entered the arbitrary text: “https://www.netnea.com/cms/wp-content/uploads/2015/10/netnealogo300_nobg.png” and clicked on OK.
  4. Selecting View->Preview looks as expected to me.

I know that this isn’t the same version as you, but are you using the same approach as I’ve used above, or are you trying to use a different process?

Thanks for your reply. I think the issue is in the domains… possibly a bug…the difference in my environment is this.

The suiteCRM is installed on “www . thedomain . com”

if I embed an image from a different domain “www . somewhereelse . com/images/theimage.jpg”, then the system performs as expected…the url stays the same.

I’m trying to link the company logo to the email template. The company logo is on the same domain as the suiteCRM install. “www . thedomain . com/images/logo.jpg”

When suiteCRM is updated on the same domain, this is when the url in the popup window changes. I think SuiteCRM is regognizing the image is hosted on the same domain and it then changes the image path to be “…/…/images/logo.jpg”

If I could somehow turn off this functionality that would be great. As of now, I’m having to go into the database tables, find the email template, then find the images and put in the full URL path. And as long as I don’t edit that template and update the image, it keeps the full path…the problem is in the editing of an image that is hosted on the same domain as the suiteCRM install I believe.

Thanks

Intuitively, this is incorrect behaviour from the software, therefore I’d suggest raising this as a bug/issue:

This is one of the easiest ways to contribute to the improvement of the software. You appear to have a really nice documentable and repeatable bug report :grin:

As a quick and dirty workaround for this, you could create a CNAME in your DNS:

SuiteCRM domain = mydomain.com
Images domain = images.mydomain.com CNAME mydomain.com

which would circumvent this messy behaviour? Obviously you then use the CNAME in your email template :thinking: …but as it seems to take quite a bit of time for the team to fix things and they’re working on a fundamentally new interface, this is probably the most expedient approach.

Thanks for the reply and suggestions…I’ll give it a shot and see how it goes. Was hoping for a quick setting in suiteCRM, but I understand better now…thanks.

Hi All

I recently updated from 7.13.0 to 7.13.3 and it seems that since then that my logo no longer appears in sent emails.
When looking at the email RAW SOURCE, it shows as …/images/email/some_logo.png, so the full URL isn’t there.

I am on a public hosted server.

As per ronedog original post this seems to be the same issue. Was there ever a fix for this or do I need to resort to the CNAME change in DNS?

Much appreciated.

Terry