Email System Warnings

in my email dashboard I get these warnings:

Warning: imap_num_msg() expects parameter 1 to be resource, boolean given in /home/XXX/crm/modules/InboundEmail/InboundEmail.php on line 392

Warning: imap_fetch_overview() expects parameter 1 to be resource, boolean given in /home/XXX/crm/modules/InboundEmail/InboundEmail.php on line 429

Warning: array_map(): Argument #2 should be an array in /home/XXX/crm/modules/InboundEmail/InboundEmail.php on line 436

Warning: implode(): Invalid arguments passed in /home/XXX/crm/modules/InboundEmail/InboundEmail.php on line 462

Warning: imap_fetch_overview() expects parameter 1 to be resource, boolean given in /home/XXX/crm/modules/InboundEmail/InboundEmail.php on line 468

Warning: usort() expects parameter 1 to be array, null given in /home/XXX/crm/modules/InboundEmail/InboundEmail.php on line 492

Warning: Invalid argument supplied for foreach() in /home/XXX/crm/modules/Emails/include/ListView/ListViewDataEmailsSearchOnIMap.php on line 130

Warning: Invalid argument supplied for foreach() in /home/XXX/crm/modules/Emails/include/ListView/ListViewDataEmails.php on line 648

Anything I need to deal with?

Thank you so much

Please always state your version of SuiteCRM, it really helps to us help you.

Normally errors shouldn’t be going up on screen, you should turn off display_errors in your config.php

But then you need to track them in the logs. Often messages are safe to ignore if you don’t have any symptom (like a function not working in the app).

1 Like

HI pgr,
thx a lot!

sorry: 7.10.6

have some issues, but not in the mail area (in other threads)
thanks for the tip to switche m off in config!

Thx a million


Hi pgr,

need help again pls :frowning:

dont find display_errors in config.php

I think I saw something with checkboxes somewhere in Admin panel? Is it that what you mean?

How would you switch it off??

Thx again


If the line isn’t there, you can add it

display_errors = false
1 Like

thank you so much!!


Hi, lived with the errors so far, but there are new ones…so tried to impleent this help, but dont know how

do i add this to any array in the config.php file?

array (
    'version' => '5.3.3',
    'contracts' => 



Hello, I’m facing the same problem on my suitecrm 7.10.7 version installation on wamp server, I searched for display_error line on the config.php file but didn’t find it and gave me more issues when I added it. Any solution for this already?


HI Gavarek, sorry to hear you face these issues… I found still no solution … :blink:


1 Like

Are you sure the IMAP PHP module is enabled in XAMPP?

Sorry if what I said before was confusing, but I have my SuiteCRM on a WAMP server, not XAMPP

Are you sure the IMAP PHP module is enabled in WAMP?


1 Like

Hello pgr, thank your for replying, I already did a small research to find out if I had the extension enabled, followed the instructions from this link:

After uncommenting the extension from my php.ini fle and restarting the server, I keep getting the same warnings, do you have another suggestion?

Thanks in advance

Before we look into other things, let me just check you got it right, sometimes this is treacherous… Please go in Admin / Diagnostics, ask for the output of “phpinfo”, download it, unzip it, and check if the php.ini you changed is the right one, and if it says that the IMAP module is effectively active.

Then do the checks for the cron jobs, which run in another PHP environment, the CLI. You can get this with the command line:

php -i | grep php.ini
php -i | grep -i imap
1 Like

Thanks for the quick reply

I went to my Wamp server main page and used the phpinfo() tool in order to verify I was checking the correct php.ini file

After validating it, I opened it and imap module extension was uncommented as well

Warnings keep appearing

Note that you didn’t follow my instructions at all :slight_smile:

If you get the information from inside SuiteCRM, I am sure it is the same settings that are effective in SuiteCRM. That is the only way to be sure. As I said, this can be tricky, hosts can be running several versions and several instances of PHP. And the cron jobs run from a different environment.

1 Like

Sorry I didn’t follow your instructions before, hadn’t clearly understand what you wanted me to do

Now I did download the phpinfo() zip after running the diagnostic tool of SuiteCRM and noticed that it is indeed the correct file with the imap extension enabled

By the way, I have my wampserver on a windows server 2016, is there any way to accomplish the functionality of the grep commands in windows?

I think there is a Windows find command which you can use to grep, but you might as well just open the file in Notepad or Notepad++ and search for the strings. Grep is just to filter output to find some string.

Please try adding display_errors=false to your php.ini and restart the web server. This should remove the errors from your screen and leave them on the logs only, which is where they should be. This is a best-practice, a normal recommended configuration.

Now pay attention to your logs (suitecrm.log and errors.log or whatever your web server log is called). There could be better clues there.

1 Like

Quick question, where and how should I be adding the display_error=false ?

Because I added it on the php.ini file but warnings still appearing on the application

Thanks in advance