Email settings Getting error !

Hi All ,

my email settings are like this

SMTP Mail Server:

SMTP Port: 587

Use SMTP Authentication: checked

Enable SMTP over ? : TLS

its working fine on my localhost ( system ) when i click on teset mail it’s sending the mail

but when i try the same settings on server ( on web )

its giving me an error like : -> SMTP server error: 5.5.1 Authentication Required.

i have enable pop and imap for my gmail account which i am using to send mail but still its working am i missing something ?

can some one please guide me on these please it will be appreciated !!!

Hi Adr,

Have you checked the error logs? Gmail does work with SuiteCRM. Have you filled in all details correctly and clicked ‘Test’ in Email Settings, without saving the settings first?



Hi will ,

in log file the error is ERROR:Password not accepted from server. Code: 535 Reply: 535-5.7.8 Username and Password not accepted.

Yes i am cheeking test mail before saving the settings

the same things works fine with localhost ?

Thanks for your time and support

Looking at the database it looks as though the settings are not being parsed correctly as they are being saved. Also this means that the view screen shows the wrong info.
The service details were being stored as ::::::imap:::: which is parsed as no additional service settings.
In a seperate test script an imap configuration that worked for me was:

$server = ‘{myserver:993/imap/ssl/validate-cert}INBOX’;

in which case i would have expected the service to be


my non ssl service is being saved as:

No luck for me yet…

I have investigated this a bit further with my very limited PHP skills.

To me it looks as though loop ‘STARTING FINDOPTIMUMS LOOP’ in modules/InboundEmail/InboundEmail.php is not working as expected.

I am using rackspace to send/receive emails and the imap works as follows:
$server = ‘{}INBOX’;

but when generating via the loop it appeared to get booted out with a login error at the service options of
‘ssl-cert-secure’=> ‘/ssl/validate-cert/secure’,
and not continue further down the array to test the service definition that I knew works:
‘ssl-cert’ => ‘/ssl/validate-cert’

So I think that the loop needs to not bail out if there is an authentication error as it appears that authentication errors are not always what they seem.

Anyway moving the array value I needed up the array makes the save process work…

Still not getting bounces to sort themsleves yet though