Email notification from Calendar is not working (no email sent)

Hi there,

I’ve searched for a solution on this issue but with no luck so I guess it’s better to ask here.

I’m new to SuiteCRM (tried vTiger and YetiForce but they are not working on my hosting site. SuiteCRM is the only one that works so far). My hosting is Site Ground. I managed to install the latest LTS SuiteCRM version 7.10.24 on the server (with PHP ver. 7.3.15). Apart from some minor bugs (e.g. some message titles and buttons showed “undefined”), everything seems to be working beside the issue I’m mentioning here right now. I’m the only admin user currently in the system.

I managed to set up the outbound email setting (I’m using a Gmail account) and all test emails got sent to my email accounts successfully, but the events that I put on the Calendar just didn’t get sent via the email notification. I’m pretty sure I ticked both he pop-up and email notifications. The pop-up notification works just fine. Tried several times and different receiver email addresses but nothing worked.

The “Run Email Reminder Notifications” in Admin->Scheduler is active, but the “Last Successful Run” shows “Never”.

Can anyone with the knowledge please give me some hints about how to solve this? Any input will be appreciated.



Hi, welcome to the Community! :tada:

For the reminders, you need to set up your scheduler jobs - you’ll find instructions specific to your installation in Admin / Schedulers, at the bottom.

I also advise you not to ignore the “minor” errors with labels showing as undefined. Those are a sure sign of broken ownerships/permissions, and SuiteCRM will break in various ways until you get that part right.

Both of these issues have a ton of threads here on the Forums with solutions, you can search to get a lot of info.

Hi pgr Team,

Thanks for the reply. I managed to ask the Site Ground customer support to set the cron job for me and the notification is working now, but they told me this cron job will be executed once every 30 minutes.

If the cron job executes only every 30 minutes, will it miss some notifications that I set up, say, 1 min before a meeting at 10:45am because the cron job has just executed at 10:30am?

I asked them this question but they told me that this is out of their knowledge and that I need to ask the SuiteCRM support…



Yes, 30m is a bit too much. They’re just being cheap.

It doesn’t have to be strictly every minute, but the usefulness of some features clearly decreases if the jobs run infrequently. You can try telling them it’s a really lightweight job, and ask them they can set it more frequently.

Do you have SSH access?

Have you resoled the undefineds issue?

Thanks mate. I think I have the SSH access (according to Can I tweak the cron job frequency by myself with it?

I haven’t solved the undefined issues and dont’ know where to start.

Sorry, I missed your reply. Did you advance anything in this issue?

On the SSH command-line you can check your crontab (probably) but it will depend on any restrictions your hosting has set for you.

crontab -l
crontab -l -e your_user_name

Ideally you would see the command your hosting support has created there, before trying to edit it.

You can also look for cron settings in CPanel.

Thanks mate. The technical support from Site Ground has told me their way to change the cron setting. By the way they don’t provide the cPanel anymore. Now on the backend of your site is a newer interface which is sleeker but less versatile than cPanel in my opinion.

They still advised me not to shorten the cron execution interval. I’ll try to find a good number to get timely notifications but at the same time not dragging the system performance.

… that would be one per minute.

Really, they’re being cheap. They’re thinking “if everybody on the shared server ran jobs every minute, we would be screwed”. But that is not going to happen. As I said, our job is light-weight, and it is running every minute in almost every server out there, including tens of thousands on shared hostings.

If they’re worried about performance, then make it run each 2 minutes. Or 3.

Thanks. Just changed the interval to every 1 min. Looks fine. :slight_smile:

1 Like