Email not working after upgrade to 7.14.3

Hello to all,

I upgraded our SuiteCRM system from version 7.12.5 to version 7.14.3 today. Unfortunately, since then, sending emails has no longer been working properly.

When calling up the email function (sending emails), the text input window is completely missing. It is therefore not possible to enter the email text.

I have already tried clearing the cache and updating the browser, but the problem persists. This is when i use firefox. In chrome the field is available but the failure missing Plugin link

Is there a known issue with this version of SuiteCRM and email sending?

Does anyone have a solution to this problem?

Thank you in advance for your help!

The email setup is COMPLETLY different in jump from 7.12 to 7.14. You’ll have to reconnect everything.

Here is a tutorial…

Thanks for this reply.
It helps a little.
But we have the problem, that dialogs not open up when you choose the emailaccoutn folders and so on.

i guess there is a failure with some files …

greetings Wolfgang

Clear you browser cache (shift F5). Maybe a bunch of times before and after the popup. I had this issue before. It was a browser cache issue. You can also try in addtion a R&R in combination with doing all the JS repair actions and then flushing your browser cache again.

I’m on the same version and no issues with the compose popup.

i use FireFox latest Version. And PHP8.1
Maybe its about this ?

i clear the cache and do a js repair.
but email bottom still empty.


I tested in firefox and it works fine for me. I have PHP 8.1 as well.

The other thing I would recommend is re-setting your file permissions.

Also check in your browser console if there are any errors.

i find some wrong file permissions - using the Browser Console. . But still missing the Email Text Field.

SuitLog offers these
Mon Jun 10 12:10:23 2024 [2034744][1][FATAL] An Imap error detected: “IMAP search error”
Mon Jun 10 12:10:23 2024 [2034744][1][FATAL] ImapHandler trying to use a non valid resource stream.
Mon Jun 10 12:10:23 2024 [2034744][1][FATAL] ImapHandler trying to use a non valid resource stream.

Thx so far…

After you have fixed the file permissions do another R&R, and all the JS repair stuff and then flush your browser cache. The imap errors I see to and don’t seem to have any ill effect.

i’ve done all these steps. Still the email Text field ist not available.
But when i set “send as Text” it opens…


On other thing you can try. I seem to remember on the server in cpanel I had the compress all content via gzip option enabled in PHP ini options. I turned this off and it solved my issue with the email. I think there was some server side caching going on.