email from name showing as "Root User" when received

After upgrading to 7.10.6 from 7.10.5 it seems I am now able to send email using the system account but with one minor problem.

If I go to Admin / Email Settings and Send Test Email it works great and when received all appears to be fine. If I go to a contact or account click on the email address to send an email from there everything looks fine too, but when the email is received at the other end the From name is showing as “Root User” rather than “My Company Name” which is what shows in SuiteCRM before clicking send.

I did previously post this as a reply to a related older thread, but I thought it might be better to post it as a new thread as it is a slightly different problem.

Thanks for any ideas.


The same here. Andyg, would you mind adding an issue on GitHub and posting the link here?

The same issue here, too. FromName is set to “Root User” here:

and then, after this commit, is not modified anymore when using the system email:

Quick fix: edit line 79 of …/include/phpmailer/class.phpmailer.php and put the “Company Name” instead of “Root User”

Posted this as an issue on Github:

Hopefully I did it right.


I have closed the Github issue I created above as I noticed issue: which would not only resolve this problem, but be a far better solution.


1 Like

Hi Andyg,

I have implemented pull request #6017 and the Root User error remained the same. Have you tried this solution yet? Did you get another result?

Changing the hardcoded variable in class.phpmailer.php did work well.

Thank you

@3boptic I did implement those changes manually as per #6017 on v7.10.6 and it solved the problem for me. I haven’t upgraded to 7.10.7 yet though, thought I’d hold off a little longer before trying it this time as I’m fairly busy with other stuff too.


1 Like

Has anyone figured this out?

I’m on 7.10.7 and implemented the change in #6017 to no avail. I no longer get “root user” but I always just get an e-mail with no “From name” field. So, all of my e-mails just show up as “alan”. I’m not sure what the difference between the “Send Test E-mail” button and sending an e-mail from within the editor in SuiteCRM is, but the send test e-mail routine seems to be properly pulling the “From name”.

I think this may relate to why I can use SMTP auth to send e-mail, but, if I try to set-up an SMTP relay, the server rejects the e-mail. The smtp relay also works with the “Send Test E-mail” as an admin user, but then fails to allow me to compose an email in the Suite editor.

And Im very interested too.

Have had the same problem since ver. 7.10.15 - tried the #6017 fix, but with no change.

From name “Root User” is not professional.

Please help :dry:


That Root user is definitely a bug. There is an easy workaround (untested, but I bet it will work) in case you can replace that string with a single value:

Change this line in the code to put in a different From Name:

include/phpmailer/class.phpmailer.php:79:    public $FromName = 'Root User';

This will apply to every user throughout the system that is experiencing this bug, so this solution won’t be good for some cases. But at least you can put your Company’s name or something.

1 Like

Hi pgr.

That helped alot - tnx.

Im very greatfull.



Totally weird. This was working correctly for me and then all of a sudden changed to Root User. Repair and quick rebuild and rebuild incoming mail accounts did not fix. But nothing has changed as far as I know. I did previously send out emails directly from contact records and then tried from both campaigns (which crashed with a return to the dashboard page - but that’s another story) and from the email module directly. Totally weird…

I upgraded to 7.10.7 over the weekend and noticed that setting line 79 in class.phpmailer.php no longer worked for me.

In my case, I’m using Amazon’s SES as my outgoing email server and the From Name was exposing my Amazon Username (which is a long string of characters)

The only way to “fix” this problem for now was to go into the SugarPHPMailer.php on line 454 in the send() function and set the $this->FromName value.

I’ll debug this issue when I have a chance, but for now this hack solves the problem for me.

I’m having this issue too

Version 7.10.15
Sugar Version 6.5.25 (Build 344)

Any movement on this?

I am convinced that this is already fixed, which version are you on now?

If anyone knows what the issue was, on GitHub, where this was being handled, that will also help us find out. I am on way too many issues at once, I get lost… :blink:

I believe this is indeed working correctly.
Its been quite some time since this was raised but I seem to remember seeing in another thread that the issue was the way the email settings had been configured. It was something about several different places that email configurations needed to be established?

This is still happening btw

@philemery - definitely try going through all email related settings. It definitely did work for me in the end. I can’t remember which email setting it was but removing and recreating all email accounts certainly fixed the problem on my side.