Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Editing fields in dashlets not working

Version 7.11.13

Sugar Version 6.5.25 (Build 344)

I cannot find the “create new dashlet” button.
So I chose one the “standard” dashlets (my open tasks) and tried to rearrange the fields from the “display columns” and the hide columns.

After manipulating the columns that I would like to see and pressing close, doing a dashlet refresh, nothing changes.

Any ideas?

@kabbott

Welcome to the community!

I tested version 7.11.20 and 7.10.22. I don’t see information about problem in version 7.11.13 too.
Look at messages in console of your browser and log of SuiteCRM.

I found the problem!
after rearranging the fields and “pressing close” (there is no save button) nothing gets saved. One has to select the dashlet name entry box and hit enter in that box, and that activates the save!

Nice find. Perhaps you can put that in a new Github issue so hopefully it can be fixed one day?
Thanks

Hi

The problem is due to CSS disabling overflow-y in the popups.
Then, the Save button is not visible when there are too many filters in the dashlet options
(this can be reproduced on demo.suiteondemand.com with the My Accounts dashlet).

We have solved that in our custom css with:

body.yui-skin-sam.masked .yui-panel-container.yui-dialog.yui-simple-dialog.shadow#dlg_c {overflow-y:scroll;}
2 Likes

Hi @blqt
Can you please share the location of the file?