Edit Workflow is not retrieving the actions


I’m using SuiteCRM Version 7.9.6.

I created a workflow with some actions, they work Ok. But if I want to edit the workflow it retrieves almost everything ok like the workflow name, when it should work and conditions, when it comes to the action part it retrieves the Select Action (create record), the action name, and the record type. And it’s not retrieving neither the fields nor relationships (actions work ok before I edit the workflow. when I save the workflow all the actions stop working).

Hope you can help me,


Maybe you’re seeing this issue?


It should be fixed in the next release, but anyway the fix seems simple enough, in case you want to try it:


Thanks for your prompt response.

Made the change and still, I’m unable to see the actions if I want to edit the workflow.

Maybe your case is different…

A few things that could help diagnose:


I tried in this www.softaculous.com/demos/SuiteCRM And the problem persists:

This is what I am trying to do:

Create a workflow for Contacts module (run once)


Create record
Name: Welcome Call
Subject: Welcome Call
Note: Give welcome information to contact.

Then I save it. If I want to edit it, It misses the Fields Subject and note, and if I add relationships also.

Hope this helps

Can you please check both your logs at these two moments:

  • when you save the workflow
  • when you reopen the Workflow and some parts don’t show?

It works now. Maybe yesterday was something in cache.


This shows as being fixed in latest version 7.9.7 however it is not. I just upgraded and it still does not appear to be functioning, where I can edit existing workflows.

I have the same issue in Workflows. I can’t add any actions or edit them in new or existing workflows

Robert, please check the GitHub issues mentioned on this thread, and try it in the online demo, and check your logs.

It would be helpful if we could debug this further.

Just a Caution to others. This issue has reappeared for me in version 7.9.8. On Actions Edit some of the fields display previously saved information and function workflows but in editing a workflow some of the action fields that were present and saved are not present but some are… Also notice that a customized field which should show a dropdown of choices does not, plus it lost its old content that was saved previously.

see notes https://github.com/salesagility/SuiteCRM/issues/4891 it does not appear to be the same as 4409 issue and I Checked and the code is correct based on the 4409 change.

1 Like

Ugh. It appears to me in this hasn’t been resolved as it’s still present in 7.8.20 LTS. Makes it impossible to edit workflows! Can someone confirm the status. Seems this is a significant bug that has been ignored, at least in LTS.

@jcrist, do you have these changes made in your code?