Each users needs to send From their own address - Outbound Email Setting?

Currently, all emails I send our show as From: crm@<MyDomain.com>.
In my profile I have checked ReplyTo and that works.
I need to send out emails through each users own email account.
There’s an “Outgoing EMail Settings” entry in Admin and I have set up individual mailboxes, but I can’t see how to use them? Where do I tell the system that a certain users uses a certain Outgoing Email Setting mailbox?

For each user … logged in as the user … go to email module … click settings tab … set up the mail details

Done that. Thank you!

In Outgoing smtp servers there are now two enties:
system Gmail (which gives the crm@<MyDomain.com> and
MyName Gmail which tests out fine to my email address.

I cannot delete the system one and I cant make My Name the default.
When I send an email, it still comes from crm@mydomain.com. In the email compose mode, there is not two options in the pulldown.

Here’s a screenshot…


entry of smtp can not be deleted because it has been released by the admin.

Go to Admin / Email Settings, here you have the users allowed to use the SMTP system. Remove the authorization and the entry disappears when user.

Thank you! Working, but a little odd.

“here you have the users allowed to use the SMTP system.”
But I don’t have that. I have a screen “Outgoing Mail Configuration.” See screenshot crmss2

If I uncheck "Allow users to use this account for outgoing email: "

Then the EMail Settings area says “Warning: Missing username and password for outgoing mail account” and will not send mail (See second attachment. crmss3)

If I Edit the “system” email with that individual’s username and password, it works – and seems to work for multiple users.

I would have expected to be able to “Add” a smtp for each user and have it use that one. Looks like it will always use “system”


yes that is something confused. The system user must have the CRM for all automated things (alerts, workflow, etc.)

Pictured however also a second SMTP is deposited. This can be set individually for the respective user, which he used to send messages.

Thank you, but I am not able to set the second the second SMTP.
There is no way to change the order, set as default, or anything else I can see.


ja diese Funktion ist nicht verfügbar und muss manuell bei jeder neuen Email ausgewählt werden…

Um das zu erreichen, ist Custom code notwendig


Yes, this feature is not available and must be manually for each new Email selected …

To achieve this, custom code is necessary

Hallo Herr Wieland,
können Sie uns bei der Lösung dieser Thematik unterstützen?
Vielen Dank!

Yes Mr. Wieland. I would also be interested in changing the default outgoing email account for all users.

If you can give any pointers, please do!


I have the same problem. I can create a second smtp for the user with user specific info, and then I can select that smtp in the drop down list in the Mail Account settings. However that selection is completely ignored and email is still sent via the system smtp. See screenshot.

OK I think I found the problem.
First I confirmed that the smtp selection is correctly stored in the database along with the other settings in the inbound_email table. No problem here.
An id in the form of random key var_char is there to identify each record – we shall call it inbound_email_id
The email composer form (when you go to email - compose) properly lets you select your email address and sets the correct inbound_email_id in a hidden form element which is correctly submitted. All good so far.
Problem starts with the Email bean object. In modules/Emails/vardefs.php there is no definition for the inbound_email_id that I could find.
So I created one by adding:

        'inbound_email_id' => array(
            'name' => 'inbound_email_id',
            'type' => 'varchar',
            'source' => 'non-db',
            'inline_edit' => false,

So now the bean engine does its magic and sets the bean inbound_email_id from the $_REQUEST data
Then next in line is the send() function in Emails.php
The send() function call the setMailer() function which is the function that sets the smtp settings (among other things).
Here is setMailer definition

 function setMailer($mail, $mailer_id='', $ieId='')

It’s 3d parameter $ieId is there to provide the inbound_email_id as one way to identify the from account. When I feed it the inbound_email_id manually it works great and sends via the correct smtp settings.
So on line 2329 of Email.php I replace

$mail = $this->setMailer($mail);


$ieId = $this->inbound_email_id;
$mail = $this->setMailer($mail,'',$ieId);

And that does the trick. Emails are now sent through the smtp settings specified with the corresponding inbound email settings.
I will post a bug report on Github


Thanks to dawansv I was able to solve this problem under version 7.9.0. Many many thanks!

However, after I updated to version 7.9.2, I started having the same problem again. My Email.php and EmailsController.php files are the same as before, but it doesn’t work for the new version.
The inbound & outbound emails are set and stored properly for each user but when I send email from a test user account, it is sent from the admin smtp account, not the user’s. But the reply_to address is correctly set to the user’s address, so the from address and reply_to address are different.

Is anyone having the same issue under 7.9.2? Any help would be appreciated!

I must admit - I am totally stumped with this. I have followed the advice in this thread.

I still cannot do the most simple thing here - that is assign the correct email address and inbox to each individual user - it just does not work.

Irrespective whether i have deselected users can use smtp (default) or not. The same result. Whichever setting is applied for one user - it is then applied to every user. Hopeless.

So, I set user A email and inbox - save it. Fine. However user A’s settings are then automatically applied to the other users - B & C. I can see now way of getting this to work.

Any suggestions, please? Why is such a simple thing so difficult in suiteCRM?

It’s a real shame.


1 Like

I have created 2 more mail account in suitecrm.

I have created custom action for workflow we is supposed to use data from variousl module and send them in a mail.
so I am sending mail using sugarphpmailer object.
Now In each record we are recording reference id which is identification of the one who need to be used as from name and email while sending mail.
we tried to set from to use email other then default email but it is not working.
It every times takes what is set in default setting.

would you please suggest necessary settings for it ?

here is the code,
$mail = new SugarPHPMailer();
$mail->From = $email_from; // it is not considered what is passed here, instead it takes default
$mail->FromName = $email_name; // It is being replace in mail content
$mail->Subject = $email_subject;
$mail->Body = $email_content;

This thread is almost 2 years old and the problems were not solved yet. What can we do to help? Adding issues and voting on them on GitHub? Help with coding? I’m interested in help the community, but this module seems a bit forgotten by the maintainers. Maybe they don’t think it’s a priority, for some reason. How many of you think this is important? Sorry, but I think that would be a great improvement for SuiteCRM. Thank you all.

1 Like

I added an issue on GitHub: https://github.com/salesagility/SuiteCRM/issues/5774 . Please comment, like, dislile, laugh or love…

It is amazing that we can’t set up the email.
I have 1 user with full capability.
Admin can send test email, but not in live mode.

Does the system allow multiple users with multiple different emails? Asking in 2019

Thank you for any insight!

E-mail module is still useless. Too slow, too many bugs, very few improvements, issue solving very slow paced. I wish I could help more. I wish more people could help. I wish email issues were top priority. I give up!