E-Mail Account Sent/Trash Folder

Having trouble with setup on an inbound email account. When I setup the IMAP parameters and test the connection, everything is fine, but when I try to select the Inbox or Trash Folder, all I get is a dialogue with a empty list box.
This is what I get for Inbox :

The trash folder gives a similar empty dialogue, but I can’t post that picture because I’m a new user.

This is an on-prem Exchange server. Any help is greatly appreciated.

Hi @mhoney,

Welcome to the Community :tada:

Do you have a personal inbound and outbound account configured in your profile? If not give that a go and then try to select the folders

Hello, and thank you for the welcome.

I do have both inbound and outbound setup for the account, and the test email works from both settings screens.

One odd thing as seen in the screenshot below, it shows both the system account and my personal account in the Outbound email section, but it says the system account is missing the username and password. This isn’t true because I can go into that account under admin>email settings and the test email works ok from there also.

Did you check both these places?

  • Admin / Email settings
  • Admin / Outbound Email settings / system account

Also, what is your SuiteCRM version?

Thank you for the reply

Both of those locations are setup with an email account and tests work in both places.

I upgraded to 7.11.18 yesterday. My original install was 7.11.17

I don’t know the exact cause, but you’re seeing that message because this function returns true:

I hope this helps you find out the problem.

Good Morning,

That clue did help a bit in that I can now login as the Admin account and get the email Inbox and Trash Folder dialogues to populate, but only for the Admin account. One thing that is confusing me is that when I go to Admin>Outbound Email Is see the following:

When I log into my personal account and look at the defined Outbound email accounts I see:
My personal account and another named “system” not “System Outgoing Mail” like I’d expect. I can’t figure out where that account “system” account is setup / configured. I went to Admin>Email Settings and the account there is setup and tests fine.

P.S. - When will I be able to add additional screenshots?

Thank you

In Admin / Email settings you define the system account. You also have a couple of checkboxes at the bottom controlling the access that other users have to that account. Trychanging that to see if it makes a difference for your case.