dropdown editor no longer works after upgrading to 7.11.6

Running 7.11.6 with php 7.3 on CentOS7 and the dropdown editor no longer works.
I can sort, but not ad or delete options.

I get an error: "TypeError: SimpleList.jstransaction is undefined[Learn More] SimpleList.js:254:13 "

I also have a cookie “sugar_user_theme” with a value of “SuiteR” – even though 7.11.6 only seems to have one theme available: “SuiteP”

Any ideas?

Just tried this, and it works for me.

Can you try a different browser? I used Firefox, latest version.

This seems to be a known issue: https://github.com/salesagility/SuiteCRM/issues/5708

But if we can’t reproduce it, we can’t fix it. We’d have to figure out what is making this work differently for you.

Maybe it’s better if we start sharing all the details: I changed the Dropdown for lead_status_dom, deleted an item called “Dead” and added an item called “Ressurrected”, with label also “Ressurrected”. I hit save and tested the Leads edit view, and it worked fine. Can you please try the same?

I would, but like I said, I can’t delete or add anything.
Clicking the trashcan icons does nothing.

Do you see any server-side errors in your logs at the time that screen renders?

No, nothing at all in error_log (php) or suitecrm.log

Just the JavaScript error “jstransaction is undefined.”

Did you try a different browser? Which ones did you try?

I tried the latest Firefox and Chrome.

Can you try a few repairs from Admin / Repairs? Anything Javascript related.

Yes, I ran all the repairs. Still no joy.
It can’t find the function jstransaction()
Where should that be defined?

That’s not complicated to search for:


but I doubt you will go very far trying to fix that - it really should just not be broken and we should try to understand what is peculiar about your system that might justify this.

A few more things we could try checking -

  • do you have any add ons installed? Can you try disabling them momentarily?

  • do you have custom code? In upgradeWizard.log, during your last upgrades, did you get warnings in this format?

No warnings about custom code in upgrade_wizard.
We have two add-on modules “Jet Mobile Pro” and “Ken Brill: Homepage Manager”
Not sure what you mean when you say “disable add-ons.”

The module loader doesn’t allow for uninstall of these.

Module Loader should allow those plug-ins to be removed… :dry:

It would be important to test this on a clone of your system without the add-ons. Unless you can debug the Javacsript setting breakpoints and stepping through the code to find out where that jstransaction should be filled correctly, but is not.

You can also try this live demo (allows admin access): https://www.softaculous.com/demos/SuiteCRM
check if it’s working there, to confirm if this is really a problem with your system, or something more.

Thanks for the link.
Yes, it works on the demo.

So, looking at the screenshot, module loader should have checkboxes beneath “Enable/Disable?”

See mine (7.11.6)…