Double Opt In Problem


I have a problem with the double Opt In.

When I change the URL of the Opt In Link the SuiteCRM don’t recognize that the customer clicked the link and is confirmed.

I also changed the config.php and changed the site-url parameter to my url but this also don’t do anything.

When I try it with the link which is set from beginning it works. But i want to redirect to another page.

Can anybody help me please.

I’m happy for every single hint


Note that there are two different settings in config.php


But I don’t understand your issue anyway. So SuiteCRM gives you a link that works, you change it, it stops working… so why exactly do you change it, and what do you change in it?

so the link looks like this when it is working:

so the x are for the suitecrm IP

and I want to change it in e.g.:

i know that the index is diffrent to the index of the but how can I the recognize the opt in??

Please let me know these 3 things

  1. Those “xx” are numbers? Is it your numeric ip address?

Did you check these two different settings in config.php?


  1. Are they using ip address or name?

  2. Can you access your SuiteCRM normally from both
and ?

for my suitecrm i´m using the ip adress of my cloud server

and i can only reach the crm from the ip not from the url

or is that in generall not possible to do it like that??

its not possible to have more urls for only one crm system??

or do you know where I can change the text of the landig page after clicking the crm ip opt in link so i can redirect to my page?

I am not sure I understand what you’re saying, but…

If you access your server with the IP address, but not with Domain name, then you probably just need to configure your Domain with your Registrar. So it is not a SuiteCRM issue, you just need to “tell the Internet” that when people go looking for it should map to or whatever.

thank you that helped me a little bit.

but now i can´t open my page anymore because it paoints the whole time to the CRM login.

is it possible to edit the Opt In file that it redirect to my page?

Because when I change the if cause where the opt in text get returned nothign happens

I edit it in the file
foreach ($uids as $uid) {
$emailMan = new EmailMan();
if (!$emailMan->addOptInEmailToEmailQueue($module, $uid)) {
} elseif ($emailMan->getLastOptInWarn()) {
} else {

    if ($confirmedOptInEmailsSent > 0) {
        $msg .= sprintf($app_strings['RESPONSE_SEND_CONFIRM_OPT_IN_EMAIL'], "test"/*$confirmedOptInEmailsSent*/);

    if ($warnings > 0) {
        $msg .=  sprintf($app_strings['RESPONSE_SEND_CONFIRM_OPT_IN_EMAIL_NOT_OPT_IN'], $warnings);

    if ($errors > 0) {
        $msg .=  sprintf($app_strings['RESPONSE_SEND_CONFIRM_OPT_IN_EMAIL_MISSING_EMAIL_ADDRESS_ID'], $errors);

    return $msg;

Which of these are using?


i`m using:


for my domain

Did you configure security certificates for that?

And check BOTH your logs when that redirect happens to the login screen. You need to fix that first…

The logs show nothing :confused:

so everything fine.

but is it possible to capture data from another page to the crm localhost?

We had similar problems and they came from the switch between https and http. Please check the URL to your site you have in emails sent out that they for sure use https: all over the line. Our problem came from forced SSL that we had on our server, so basically we did not recognize that we had http: in site_url that was used for all generated links. When somebody clicked these links in our emails the session were broken when the entry into the Suite CRM was forced to use https: but the link used http:.

If you are sure you have site url starting with https then you should check email templates that you really do not have changed anything that bypasses the site_url parameter. If you only have an IP adress access without domain name then it should work as well with https: if your server has a valid SSL certificate. Some servers are configured to have port number for SSL at the end of the URL, normally “:8080” at the end of the IP address.

Hope something of these thoughts may help you…

1 Like